PHPize Fails - MMCache 2.4.6

Help
Anonymous
2004-03-22
2004-03-31
  • Anonymous - 2004-03-22

    Hi,

    I'm having great trouble getting the PHPIZE command to work.

    -----------------------
    root@perception [/usr/local/src/turck-mmcache-2.4.6]#
    $PHP_PREFIX/bin/phpize /usr/local/php/bin/phpize: line 52:           
    /usr/local/php/lib/php/build/phpize.m4: No such file or directory aclocal:
    `configure.ac' or `configure.in' is required
    -----------------------

    I have a (I thought) standard install of PHP4.3.4 in /usr/local/src.  I
    have compiled "-- with-apache" and "standalone" versions of php.  The file
    "/usr/local/php/lib/php/build/phpize.m4" does exist, and is 2231 bytes.

    The machine is a P4 HT Redhat machine.  "uname -a" reports:

    Linux perception 2.4.20-28.9smp #1 SMP Thu Dec 18 13:37:36 EST 2003 i686
    i686 i386 GNU/Linux

    Autoconf: autoconf (GNU Autoconf) 2.57
    Automake: automake (GNU automake) 1.6.3
    Libtool: ltmain.sh (GNU libtool) 1.4.3 (1.922.2.111 2002/10/23 02:54:36)
    M4: GNU m4 1.4.1

    Any help you can offer would be greatly appreciated!  I am at a loss, and
    have scoured the web without find many if any hints!

    Cheers!

    Jason.

     
    • Alex Rozhik

      Alex Rozhik - 2004-03-22

      You are not alone in this trouble :(

       
    • Anonymous - 2004-03-23

      Here the step by step which works for me:
      1. Try to upgrade your libtool to ver 1.5.2
      2. Make sure the prefix of all component is same like in /usr/local, example:
      when configure libtool:
      ./configure --prefix=/usr/local

      and when install php:
      ./configure --prefix=/usr/local

      3. I have the similar problem which the real prefix is in "/usr" but when i tried to install new version of libtool in his default prefix (/usr/local), and i run the command "libtool --version", my machine give the old version of libtool.
      Hope this is work.

       
    • Anonymous - 2004-03-25

      Thanks for your suggestions and help.  I have updated to the latest libtool, autoconf, and automake, with everything in /usr/local/ and reinstalled php in /usr/local/ but it's still giving the same error. 

      Help, please!!!

       
    • Anonymous - 2004-03-25

      Just in case anyone wants to know...

      automake (GNU automake) 1.8
      autoconf (GNU Autoconf) 2.59
      ltmain.sh (GNU libtool) 1.5.2 (1.1220.2.60 2004/01/25 12:25:08)
      PHP 4.3.4 (cgi) (built: Mar 25 2004 07:25:36)

       
    • Anonymous - 2004-03-25

      And the error changes of course to:

      /usr/local/bin/phpize: line 52:             /usr/local/lib/php/build/phpize.m4: No such file or directory
      aclocal: `configure.ac' or `configure.in' is required

       
    • Anonymous - 2004-03-31

      1. Could you see in http://turck-mmcache.sourceforge.net that say something like "Turck MMCache does not work in CGI mode" ??

      2. If you are not using CGI mode in Apache, try to not configure PHP with CGI enabled.

      3. Here is my configuration of PHP, maybe helpfully:

      ./configure --prefix=/usr/local --with-mysql=/usr/local/mysql --with-apache=../apache_1.3.29 --enable-track-vars --enable-wddx --disable-debug --enable-sigchild --with-zlib

       
    • Anonymous - 2004-03-31

      ohh.. and don't forget after successfull re-installed PHP, copy "php.ini-dist" to /usr/local/lib/php.ini

       

Log in to post a comment.