Not active

Help
Sigurd Nes
2003-10-27
2013-06-04
  • Sigurd Nes

    Sigurd Nes - 2003-10-27

    I get this message from mmcache.php:
    "Turck MMCache 2.4.4 is not active! It doesn't work in CGI or command line mode!"

    I have configured php with "--disable-cgi" - and there is no mention of CGI in httpd.conf - but still Turck MMCache won't start.

    How can I sort this out?

    redhat 9
    PHP Version 4.3.3
    Apache 1.3.28
    Turck MMCache 2.4.4

    ./configure --disable-cgi --with-imap=../imap-2002d --with-sybase-ct=/usr/local/freetds --with-apache=../apache_1.3.28 --with-mysql=no --with-pgsql --enable-mail --enable-xslt --with-xslt-sablot

     
    • Dmitry Stogov

      Dmitry Stogov - 2003-10-28

      I already know about this problem. I hope I have solved it in development version.

      Can you modify "mmcache.c" and remake it.

      mmcache.c: 4549
      +      if (getpid() != getpgrp()) {
      -      sleep(0);
      -      if (getppid() != 1) {

      Please, let me know if it helps or not.

       
      • Sigurd Nes

        Sigurd Nes - 2003-10-28

        It worked

        Thanks !

         
      • Marco A. Mateos

        Marco A. Mateos - 2004-11-03

        I'vethis

        /*
              sleep(1);
              if (getppid() != 1) {
        */
              if (getpid() != getpgrp()) {
                return SUCCESS;
              }
            }

        Butdon'twork..
        Justyesterdaywork.NowrecompilingApache,PHPandbrokemmcache.

         

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks