MMCache problems compiling on FreeBSD-4.8

Help
2003-06-13
2003-06-17
  • Forrest Aldrich

    Forrest Aldrich - 2003-06-13

    I have PHP-4.3.2 and Apache-1.2.27 installed.

    Most everything else is up-to-date (FreeBSD-4.8).

    Here are the problems I see:

    ===> Configuring for turck-mmcache-2.3.15
    configure: WARNING: you should use --build, --host, --target

    checking ext/session/php_session.h usability... no
    checking ext/session/php_session.h presence... yes
    configure: WARNING: ext/session/php_session.h: present but cannot be compiled
    configure: WARNING: ext/session/php_session.h: check for missing
    prerequisite headers?
    configure: WARNING: ext/session/php_session.h: proceeding with the
    preprocessor's result

    cc: unrecognized option `-prefer-pic'

    Any clues about how to fix this?

    I emailed the FreeBSD port maintainer, and freebsd-ports, but no replies.

    Thanks,
    Forrest

     
    • Forrest Aldrich

      Forrest Aldrich - 2003-06-17

      I can't possibly install this on my server without having some explanation of these compile problems.

       
    • Anonymous - 2003-06-17

      Check out the latest port from the FreeBSD CVS repository.  I had the same problem with 4.8 and 5.0, until I did that.

      URL:  http://www.freebsd.org/cgi/cvsweb.cgi/ports/www/turck-mmcache/

      Port as tarball:
      http://www.freebsd.org/cgi/cvsweb.cgi/ports/www/turck-mmcache/turck-mmcache.tar.gz?tarball=1

       
      • Forrest Aldrich

        Forrest Aldrich - 2003-06-17

        I reported the problem to the port maintainer, so I see he's fixed it, at least.  What was the problem?

         

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks