Apache 1.3.26 dies w/graceful restart+MMCache

Anonymous
2004-03-26
2004-08-06
  • Anonymous

    Anonymous - 2004-03-26

    I'm running SuSE Linux Enterprise Server 8.2 X86_64 which uses Apache 1.3.26 and PHP v4.2.2 and have added Turck MMCache version 2.4.6. The system is running Linux 2.4.21 on a dual AMD64 Opteron (64-bit system).

    It runs well with Turck...except when logrotate sends apache a reload signal (SIGUSR1) which then causes Apache to reload gracefully. Apache logs receiving the signal in the error log and then logs that it's reading the configuration files. At the very last configuration file (nothing special, just vhosts) there is no other message. Apache is effectively dead. No httpd processes are running at that point, and I have to do apachectl start to get it going again.

    Everything works fine with apachectl restart (which does a start/stop) but not with SIGUSR1 (reload).

    My other server runs SuSE 9 and has Apache 2.0.48 and PHP 4.3.3 and does NOT exhibit this behavior. It gracefully restarts without any problem, using the same Turck MMCache v2.4.6.

    I tried enabling DEBUG when compiling MMCache and in the php.ini (setting mmcache.debug="1") and got debug output but only that MMCache was indeed getting hits to the pages. When I did the graceful restart, I received no error messages or warnings.

    Any help would be appreciated :D

     
    • Anonymous

      Anonymous - 2004-03-26

      One other thing I forgot to mention:

      The SuSE 9 system that works fine with Turck MMCache is an Intel P4 not AMD Opteron.

       
    • Charles Sprickman

      I know this is old, but I see the same thing with SIGUSR1 on apache 1.3.29, php 4.3.6 and mmcache 2.4.6 on FreeBSD 4.8, AMD Duron.

      However Apache will continue to serve requests after the graceful restart.  And a simple restart produces no ill effects.

       
    • Adrian Madrid

      Adrian Madrid - 2004-08-05

      I have the same problem with Red Hat Enterprise Linux ES release 2.1 (Panama), apache-1.3.27-8.ent, PHP 4.3.7 and Turk 2.4.6 and 2.4.7CVS. If I turn off mmcache graceful works just fine. The biggerst problem is that the system is set up to do a graceful restart to rotate logs and that used to kill apache every night at 3am. Now I changed that to do a full restart but then that restart the cache and kills all the session at the moment. There has to be a better way. HELP!

       
    • Adrian Madrid

      Adrian Madrid - 2004-08-06

      On a hunch I changed my session handler from mmcache back to files and, voila!, now it doesnt die after a graceful restart. Isn't it great! Not really, I'd rather use mmcache for sessions but I gues it would have to do for now.

       

Log in to post a comment.