Problem with 2.4.7-CVS (and fix?)

2004-04-21
2004-05-07
  • rodrigo diaz
    rodrigo diaz
    2004-04-21

    Hello

    I'm trying to get working the latest cvs version but I have had a problem with a line in mmcache.c

    I've had to modify the next line. Now all is working properly:

    line 4322 of mmchache.c:
    STD_PHP_INI_ENTRY("mmcache.compress_level", "9", PHP_INI_ALL, OnUpdateLong, compress_level, zend_mmcache_globals, mmcache_globals)

    replace with:
    STD_PHP_INI_ENTRY("mmcache.compress_level", "9", PHP_INI_ALL, OnUpdateInt, compress_level, zend_mmcache_globals, mmcache_globals)

    I've only replaced OnUpdateLong with OnUpdateInt.

    Now all works.
    My config.
    Linux RH8
    Apache 2.0.49
    PHP 4.3.6

    Is my fix dangerous?

    If I replace OnUpdateLong with mmchache_OnUpdateLong the apache server doesn't start and with no erros in apache or php log.

    Regards

     
    • Gabriel Ricard
      Gabriel Ricard
      2004-05-07

      I ran into the same problem, and your fixed worked. If mmcache is using zlib for compression, 9 is the maximum compression level anyways, isn't it? That wouldn't require a long, an int would be way more than enough there.

       
    • Hős Endre
      Hős Endre
      2004-05-07

      Thank you! This bug have been fixed in CVS, please check out the thread "Apache restart segfault & build problems".