#47 Problems with includes and phpBB

open
nobody
None
9
2003-09-29
2003-09-29
Specka
No

On certains pages with any script (phpBBForum 2.0.5 y
2.0.6) and own pages, I get errors.

Fatal error: Cannot redeclare renumber_order()
And on own scripts, a include not render php to html.

Any sugestion?

Discussion

  • Dmitry Stogov

    Dmitry Stogov - 2003-09-29

    Logged In: YES
    user_id=124551

    Thank you for your report. I alreafy know about this BUG, but
    I don't know how to fix it. This BUG is releated to Zend Engine
    and runtime/compiletime function redeclaration.

    Zend Accelerator and Zend Encoder have excectly the same
    BUG.

     
  • Dmitry Stogov

    Dmitry Stogov - 2003-09-29
    • priority: 5 --> 9
     
  • Nobody/Anonymous

    Logged In: NO

    I have experienced the same issue with phpBB

     
  • Elliot Fong

    Elliot Fong - 2003-11-10

    Logged In: YES
    user_id=97044

    phpBB works perfectly fine for me...

     
  • Nobody/Anonymous

    Logged In: NO

    It's because you have statistics module installed. You can fix
    it by editting admin/admin_statistics.php and
    change "renumber_order" to "stats_renumber_order" (in to
    places)

     
  • Nobody/Anonymous

    Logged In: NO

    Dmitry,

    I myself have tried three accelerators until now, and they are:

    1) Zend's PerformanceSuite
    2) Turck's MMCache
    3) phpAccelerator

    I know the problem if ``cannot redefine function XXX``
    because my applications caused both Zend's and Turck's
    accelerators to fail always.

    The only accelerator that never experienced ANY difficulty
    with my applications, and worked just out-of-the-box, is the
    latter of the three -- phpAccelerator.

    I know that tests show superiority of Zend's and Turck's
    accelerators over phpAccelerator, but no one wants to deploy
    a buggy extension, right?

    You better find a quick fix for this piculiar bug...

    TIA, Anon

     
  • Comrax(R) Ltd.

    Comrax(R) Ltd. - 2003-12-17

    Logged In: YES
    user_id=437645

    But ionCube's phpAccelerator does not have any problem with
    ``function redefines`` and works exactly as expected after
    deploying it.

     
  • Dimitri Tarassenko

    Logged In: YES
    user_id=610597

    I've experienced similar problems with TUTOS.

     
  • Nobody/Anonymous

    Logged In: NO

    What is the status of this bug? Is somebody working on it?

     

Log in to post a comment.