Compile files on Redhat ES 3.0

Help
2003-11-20
2004-04-10
  • Chris Garringer

    Chris Garringer - 2003-11-20

    Redhat is no longer distributing tripwire as of 3.0 so I downloaded 2.3.1-2 and tried compiling.  I got the followin g error, any ideas on what is missing?mkdir -p obj/GCC/Release
    c++ -I../stlport -Wall -W -Wno-sign-compare -Wno-unused -Wno-uninitialized -ftemplate-depth-32 -O2 complex.cpp -c -o obj/GCC/Release/complex.o
    In file included from ../stlport/complex:40,
                     from complex.cpp:21:
    ../stlport/wrap_std/complex:16:39: ../g++-include/complex: No such file or directory
    complex.cpp:26: syntax error before `&' token
    complex.cpp: In function `float abs(...)':
    complex.cpp:28: `__z' undeclared (first use this function)
    complex.cpp:28: (Each undeclared identifier is reported only once for each
       function it appears in.)

     
    • Simon Massey

      Simon Massey - 2004-01-06

      I had this problem (using Fedora Core1). The issue appears to be that the build files dont work with gcc3. If you apply the gcc3 build patch from this page and follow the examples it compiles.

      http://www.linuxfromscratch.org/blfs/view/stable/postlfs/tripwire.html

      The problem is that for me after the build and install the twadmin program can make the site keys but core dumps when it tries to make the config file with:

      ...snip...
      [root@charity tripwire-2.3.1-2]# twadmin --create-cfgfile --cfgfile $DIR/tw.cfg --site-keyfile $SITE_KEY $DIR/twcfg.txt
      Please enter your site passphrase:
      Software interrupt forced exit: Segmentation Fault
      Abort
      [root@charity tripwire-2.3.1-2]#

       
    • Hans Kind

      Hans Kind - 2004-01-18

      Has anyone been able to get tripwire working on Red Hat Enterprise Linux WS 3?

      Keep running into this Software interrupt forced exit: Segmentation Fault error.

      rgds

      Hans Kind

       
    • Anonymous - 2004-04-06

      i get the same error on Redhat ES 3 (Taroon Update 1)
      :

      Software interrupt forced exit: Segmentation Fault

       
    • Anonymous - 2004-04-06

      well, i just installed the RPM from the Redhat 9 FTP and it installed, --init'd and --check'd fine....seems to be the solution....
      ?

       
    • Sonny Zambrana

      Sonny Zambrana - 2004-04-10

      That's a pretty weak workaround.  I would like to see it be able to work with gcc 3.

       

Log in to post a comment.