Might be too late, but I think using "isInf" for both for enabling the use of a unit with both the "Paratroop" Tech AND the "Mech.inf" Tech is suboptimal design. It does not allow to create separate units for these Techs anymore, and a later change to that would cause some hazzle or require old maps to be adapted.
Think the initial idea was good. Unit should be able to receive both "isInf" (enabling Mech.Inf Technology) and/or "isPara", enabling Parachutist Technology.
Maybe Tech and property should even be named more general "isAirTransport" and "isAirTransportable".
Just my 2 Cents.