#8 can't activate presets under 0.1.7

1.0
open
nobody
presets (1)
2014-05-19
2013-08-21
No

I don't seem to be able to activate any of the included presets in triceratops under A3 nor qtractor.

tri. 0.1.7 running under KXStudio amd64

Ardour 3.3 and qtractor 0.5.10

Discussion

  • Nick Bailey

    Nick Bailey - 2013-09-13

    is this from source or .deb package?

     
  • jhammen

    jhammen - 2013-10-15

    presets not selectable under Qtractor 0.5.11 using package 0.1.7-0kxstudio1

    preset selection however does work using latest source triceratops-lv2-v0.1.7.tar.gz

    (using stock Ubuntu 13.04)

     
    Last edit: jhammen 2013-10-16
  • Daniel MacDonald

    jhammen is correct. I uninstalled the KXStudio package and compiled 0.1.7 myself and now I can change presets fine although a number of the presets don't work for me (they don't make any sound) including:

    aceeeed
    dominator
    flimsy_pw
    fm_twangy
    grossriser
    lazer_bass
    lazer_harp2
    nasty_square
    both nice_square_mod presets
    operatic
    raggy_rasp
    sample_and_hold
    sh101_esque
    All sync_ presets except sync_lead, which works
    synths_had_a_drink
    test_square

    I'll try the git code to see if that fixes these presets.

     
  • Daniel MacDonald

    The presets in the above list are still not working for me under the latest git version of Tri under latest svn qtractor with the exception of grossriser which works now.

     
  • Daniel MacDonald

    grossriser isn't working so well under git either actually. It works for a few seconds then stops producing sound.

     
  • Steven Grace

    Steven Grace - 2014-05-04

    I have the same issue. I installed package "triceratops-lv2" from the Arch Linux AUR repository (version 0.1.7-1). I can move through the presets but I can't select any of them. I've tried Triceratops in both Qtractor and jalv.gtk; in the latter it spews the message "UI write to out of range port index -1" to the terminal I started "jalv.gtk" from.

     
  • Steven Grace

    Steven Grace - 2014-05-17

    I tried version 0.1.9. I can now "select" an individual preset (under certain conditions) but it doesn't actually load. In other words, the preset browser is still broken.

    I also noticed problems with wrong preset file names, an invalid assumption regarding the presence of ~/.lv2/, and other issues, but that's probably off-topic for this bug.

     
  • Nick Bailey

    Nick Bailey - 2014-05-19

    but again is this from the source here or deb package? I can't get the deb package to load the presets myself not worked out the cause yet, I'm working on it

     


Anonymous

Cancel  Add attachments