Il 20/dic/2013 09:54 "Kasparek Tomas" <kasparek@fit.vutbr.cz> ha scritto:
>
> On Fri, Dec 20, 2013 at 09:27:09AM +0100, Giulio Paci wrote:
> > Il 20/12/2013 08:45, Kasparek Tomas ha scritto:
> > > On Fri, Dec 20, 2013 at 07:21:20AM +0100, Giulio Paci wrote:
> > >> Great news! :-) Are you trying to compile 1.5.2? If yes, please, try to
> > >> compile the git version instead. If you are already using the git version,
> > >> I will investigate further.
> > >
> > > git 639693ba1b812bf29b258da36870f144aa2ec4ce
> >
> > $ make
> > gcc -O -fPIC -DUSE_TCL_STUBS -DUSE_TK_STUBS -I/usr/include/tcl8.6/tcl-private/generic -I/usr/include/tcl8.6/tk-private/generic -I/usr/include -I/usr/include -DTCL_81_API
> > -c -o axis.o axis.c
> > axis.c: In function ‘AxisCmd’:
> > axis.c:223:10: error: ‘Tcl_Interp’ has no member named ‘result’
> >     interp->result = Tk_PathName(axisPtr->tkwin);
> >           ^
> > make: *** [axis.o] Error 1
>
> The same for mw, -DUSE_INTERP_RESULT make it compile. Right now, I'm able
> to run transcriber, but when I select any file in initial open dialog it
> crashes (with some the waveform is loaded under, so it probably does some
> processing).
>
> So the only modification except for Makefile for the upper define is
> Main.tcl:
>
> proc LoadModules {} {
>  ...
>  lappend auto_path "c:\TransBin\lib\Snack"
>  lappend auto_path "c:\TransBin\lib\tcltk\transcriber1.5"
>  lappend auto_path "c:\TransBin\lib\TcLex21a1"
>
> (this is just for archive and me to remember the changes)
>
> > This lead me to another question: where did you get tclex? AFAIK most of
> > the versions that you can find do not work with recent versions of tcl/tk
> > (> 8.4).
> This was one of the biggest problem. I wanted win binaries and the only one
> I found are: http://tcltk.co.kr/node/73, These seems for 8.0,8.1,8.2 tcl/tk
> according to the names inside, but have nothing better now.
>
> Does anybody have better/newer tclex win binaries?

AFAIK no. You can obtain working sources by using the patches contained in the Debian package sources.

> > > (second thing - in sf.net download these new 1.5.2 are in 1.5.1 folder, is
> > > this intended, or should this be fixed?)
> >
> > I also add another question: where are the 1.5.2 sources? May we tag a specific git revision?

> No idea. :-)

These questions are directed to Claude. :-)

Bests,
Giulio.