No route to host

  • Mike Gibbons

    Mike Gibbons - 2012-01-12

    I run t-plan under Ubuntu 11.04 with connection to a WinXP machine under Virtualbox on my local network

    When I run the t-plan script from a terminal it works fine but when I run it from cron under my own username it fails with a no route to host message.

    The script is:

    VBoxHeadless -vrdp=off -startvm WinXP &
    sleep 60
    cd /home/mike/tplan
    ./ -c -r /home/mike/vncrobot/telechartDaily -n

    My log file shows:

    T-Plan Robot version 2.0, Copyright (C) 2009 T-Plan Ltd.
    T-Plan Robot comes with ABSOLUTELY NO WARRANTY; for details
    type `robot -license'.
    This is free software, and you are welcome to redistribute it
    under certain conditions; type `robot -license' for details.

    T-Plan Robot v2.0.Beta (Build No. 2.0.Beta-20090824.1) - automated testing tool based on remote desktop technologies.
    Copyright (C) 2009 T-Plan Ltd, All rights reserved.

    Network error: no route to server:
    Failed to connect to Network error: no route to server:
    Connection to winxp failed (Error NT_STATUS_BAD_NETWORK_NAME)

    I know the machine is reachable because from a terminal I can connect with vncviewer (no authentication needed)

    I have spent several hours on this so any help would be greatly appreciated.

  • Mike Gibbons

    Mike Gibbons - 2012-01-12

    I should have mentioned that the WinXP machine is running vncserver.

  • Robert Pes

    Robert Pes - 2012-01-12

    The Java documentation on NoRouteToHostException says:

    Signals that an error occurred while attempting to connect a socket to a remote address and port. Typically, the remote host cannot be reached because of an intervening firewall, or if an intermediate router is down.

    As I understand the error the IP address is known but it is blocked by the firewall or by the linux kernel for the cron tasks. This is a Linux system configuration problem. Get the Ubuntu support forums to help you.


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks