VNC connection dying right after connecting

  • Leah Klearman

    Leah Klearman - 2012-04-13

    Hi, I've just downloaded TPlanRobot 2.0.6 on my Mac (JDK 6, OSX 10.7)
    And I'm trying to connect to either/both a Win7 (TightVNC server) or WinXP (RealVNC server).
    In both cases, the connection is established, it tells me that there is a window size mismatch, and no matter what I answer about how to deal with the windows, it flashes a view of the desktop for a millisecond, then disconnects.

    Any idea what's causing it and how to fix it?


  • Robert Pes

    Robert Pes - 2012-04-14

    There might be a quite a few reasons.

    1. Make sure that you are not connected to the same VNC from another viewer. Two simultaneous connections in the VNC exclusive mode make the server to terminate one of the sessions.

    2. Try to connect from another VNC viewer. If you succeed and the connection is stable it will rule out intermittent network failures.

    3. Start Robot from a terminal as follows:

    java -Dvncrobot.rfb.debug=true -jar robot.jar

    Then reproduce the connection failure and post the terminal logs to this forum. It will tell us the point the connection gets terminated at. Though it's difficult to say without seeing any data it is possible that the server doesn't like one of the VNC session settings such as the encodings or the pixel format. To modify these simply Go to Edit->Preferences in the Robot GUI and select the "RFB (VNC) Client" node in the tree. The safest configuration (and also the slowest) is to remove all encodings except for the Raw one. You may also make Robot to force one of the available pixel formats.

  • Leah Klearman

    Leah Klearman - 2012-04-16

    looks like encoding was in fact the culprit. RAW turned out to be too slow…by the time I could see the menu over here, it had already disappeared over there. setting it to RRE only seems to be working for at least one of the machines. I will make this the first thing I should check when I have this kind of problem.

    Thank you,


Log in to post a comment.