Solaris install/exec issue QString seg fault

Help
schwerwolf
2004-12-08
2012-12-13
  • schwerwolf

    schwerwolf - 2004-12-08

    Here's what I've done:

    Compiled and linked tora-1.3.14.1 to Qt-free-3.3.3 and Oracle 9.2.0. Qt-free was compiled and linked statically with multithreaded support. All compilation and linking was done using Sun's CC compiler version 6 update 2.

    I can execute tora-static or tora-mono (I've tried both). The first splash screen appears. I press okay and it segfaults. The segfault occurs on a call to QString::setLength(uint newLen) in the Qt library.

    Has anyone successfully installed TOra on Solaris using Sun's compiler? I'd like to hear a happy ending.

     
    • schwerwolf

      schwerwolf - 2004-12-08

      My elation at successfully compiling Qt on solaris was premature. Qt core dumps on any interaction after load.

      I will attempt to correctly compile Qt and post my results thereafter.

      I'd still like to know of someone who has successfully installed TOra on Solaris using CC.

       
    • schwerwolf

      schwerwolf - 2004-12-10

      The install of Qt works now, but I still have issues. I had to compile Qt with g++ (3.4.2) in order for it to work.

      In summary:
      CC(WS6U2) + STL support => seg faults on execute of TOra.
      g++(3.4.2) + STL support => compile errors: (::vfwscanf not declared...)

      TOra uses STL, so I figured that is the crux of the problem. Once I can compile Qt with STL support using gcc, I should have a working TOra. Any suggestions?

       
    • schwerwolf

      schwerwolf - 2004-12-21

      The only solution I have found is to compile and link Qt and tora using an updated compiler. Sun One Studio 9 I think.

      That compiler handles STL much better and can compile both Qt and Tora without problems.

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks