RAW(x) display issue schema browser

Yves Royer
2011-06-07
2012-12-13
  • Yves Royer

    Yves Royer - 2011-06-07

    Hi all,

    I'm quite new to TOra. I'm used to work with TOAD and PL/SQL Developer but now i'm looking for a free alternative.

    While working with TOra I've noticed that in the schema browser binary data like RAW(x) fields are being displayed as binary text. The project I work for now uses RAW(16) columns as PK's throughout the whole database. When browsing tables it would be quite usefull if the schema browser would apply the "RAWTOHEX" function implicitly. If I now want to see a textual representation of a PK/FK I have to use a query windows and create a select statement with the RAWTOHEX function applied on each RAW(16) field… .

    There used to be a bug (ID 2944747) but it should be solved.

    I use TOra 2.1.3 on a W7 x64 system.

    Greetz

     
  • Ivan Brezina

    Ivan Brezina - 2011-07-04

    This was fixed in a branch which uses alternative wrapper for Oracle's OCI library.
    (I'll try to create a Win32 build of it a will publish it somewhere)

    Ivan

     
  • Yves Royer

    Yves Royer - 2011-07-05

    Thx for the reply! Looking forward for a new version :-)

     
  • Ivan Brezina

    Ivan Brezina - 2011-07-07

    Hi I've uploaded experimental build for win32 into a folder tora-experimental on source forge. It does not have any installer.
    It should be executable from any location.

    Most of the users who complain about Tora have problems with locating Oracle client libraries. The procedure of detecting and loading Oracle libraries is much more tricky on Windows then on Unix. And since Tora is mainly developed on Linux
    no one worked on it to solve it correctly.

    In order to use this build you should:
    - Download an install "Microsoft Visual C++ 2010 Redistributable Package (x86)"
    - Download and install Oracle instant client(11GR2) (32bit version)
    - In the system setup set environment variables: PATH, ORACLE_HOME, TNS_ADMIN to point into the directory containing
      Oracle instanclient
    - Create a file tnsnames.ora in Oracle instant client directory.

     
  • Yves Royer

    Yves Royer - 2011-07-07

    Hi there,

    I found the download and tried the build. It works! :-)

    I don't know what the difference is between the tora-otl.exe and toa-trotl.exe but when I start TOra with the first exe, everything works fine. If I start TOra with the second exe, i get the following error a couple of times:

    File error

    Couldn't open /tnsnames.ora for readonly

    OK  

    I can however after clicking "ok" a couple of times, select a stored connection setting and do what i want to do in TOra.

    Greetz,

    Yves

     
  • Ivan Brezina

    Ivan Brezina - 2011-07-07

    This is just a debugging warning. If you set env. variable TNS_ADMIN to a directory containing file tnsnames.ora it will disappear.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks