#594 "grid propagate .win 0" incorrect behavior

obsolete: 8.1
closed-fixed
nobody
49. [grid] (33)
2
2001-04-04
2000-10-31
No

OriginalBugID: 2286 Bug
Version: 8.1
SubmitDate: '1999-06-25'
LastModified: '2000-04-17'
Severity: MED
Status: Released
Submitter: techsupp
ChangedBy: ericm
OS: All
Machine: X86
FixedDate: '2000-04-17'
FixedInVersion: 8.3.1

Name:
daniel barrett

Extensions:
BLT, IMG

Comments:
Since "grid propagate .test 1" works properly, propagation off can be
guaranteed by proceeding the off command with an on command:
grid propagate .test 1
grid propagate .test 0

ReproducibleScript:
% frame .test
.test
% grid .test
% grid propagate .test 0
% grid propagate .test
0
% grid propagate .test 0
% grid propagate .test
1

ObservedBehavior:
The "grid propagate .test 0" acts as a toggle, rather than a switch. If
applied to a widget with propagation already off, it will turn it back
on.
Turning propagation on with a positive boulean works as expected, as do
the pack propagate commands.

DesiredBehavior:
grid propage .test 0 should always result in propagation off for the
specified widget (.test).

Verified in 8.3a1.

- eric

-- 01/05/2000 ericm

There was a some bad logic in the [grid propagate] routine; I corrected this, and the fix will go out with 8.3.1.

- eric

-- 04/17/2000 ericm

Discussion

  • Brent B. Welch

    Brent B. Welch - 2000-10-31
    • priority: 5 --> 2
    • status: open --> closed-fixed
     
  • Don Porter

    Don Porter - 2001-04-04
    • labels: 104343 --> 49. [grid]
    • summary: "grid propagate .win 0" incorrect behavior --> "grid propagate .win 0" incorrect behavior
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks