#3026 Cocoa 8.5.12 backport still crashes in IDLE clipboard copy

obsolete: 8.5.12
closed-works-for-me
5
2012-11-05
2012-10-09
Ned Deily
No

With a current Tcl/Tk built from the tk-cocoa-8-5-backport branch on OS and a Python that dynamically links with it, attempting to use clipboard copy in Python IDLE's causes Tk to crash. A more general problem with clipboard copies in Text widgets was reported in #3555211 (https://sourceforge.net/tracker/?func=detail&aid=3555211&group_id=12997&atid=112997) which was addressed in Fossil checkin 2fe193d134 on 2012-08-07 (http://core.tcl.tk/tk/info/2fe193d134). That checkin resolved some of the crashes but crashes with IDLE still remain. By the way, it appears that the original clipboard copy regression (as reported in #3555211) was introduced by fossil checkin 90d4b8b59c of 2012-07-25 (http://core.tcl.tk/tk/info/90d4b8b59c).

The orginial problem documented in #3555211 was first noticed with the release of ActiveTcl 8.5.12.0. ActiveTcl 8.5.12.1 apparently includes checkin 2fe193d134 and exhibits the problem documented in this issue as still seen with current tip. The previous ActiveTcl version 8.5.11.1 does not exhibit this problem with IDLE.

To reproduce, install either the current OS X ActivePython 2.7.2 (http://www.activestate.com/activepython/downloads) or an OS X 64-bit/32-bit python.org python (http://www.python.org/download/), install Tcl and Cocoa Tk 8.5 in /Library/Frameworks, launch IDLE (for example, type /usr/local/bin/idle2.7 in a shell). Then when the IDLE PyShell menu appears, use the mouse to doubleclick on some text in the PyShell window (for example "copyright"), then use the mouse to select Edit -> Copy from the menu bar. Using a debug build of Cocoa Tk at current tip (77b3f433c7), the crash occurs at TkpMakeWindow + 465 (tkMacOSXEmbed.c:169). See the attached crash dump. Further observations: The crash seems to only occur using the ActivePython 2.7.2 when selecting the Edit->Copy menu item (and not by using its keyboard accelerator Command-C) and only occurs if no other clipboard copies have succeeded; that is, if you use Command-C first, then Edit->Copy does not cause a crash. Behavior with at least some python.org Python 3.3 (tested with 3.3.0rc1) is different in that the crash occurs using either Command-C or Edit->Copy, unlike 2.7 where only Edit->Copy crashes.

http://bugs.python.org/issue15574

Discussion

  • Ned Deily

    Ned Deily - 2012-10-09

    OS X crash dump of IDLE copy clipboard menu crash

     
  • Kevin Walzer

    Kevin Walzer - 2012-10-09

    Since the commit that the OP indicates in this bug, Tk-Cocoa has been merged into the core-8-5-branch, and this bug is not present in a build of Tk against the head of core-8-5-branch as of 2012-08-08; nor is it present in IDLE.

     
  • Kevin Walzer

    Kevin Walzer - 2012-10-09
    • assigned_to: das --> wordtech
    • status: open --> closed-works-for-me
     
  • Kevin Walzer

    Kevin Walzer - 2012-10-09
    • status: closed-works-for-me --> open-works-for-me
     
  • Ned Deily

    Ned Deily - 2012-10-09

    Running a quick check, it does appear that the this problem is no longer is present with the current head (71332f1481) of the merged core-8-5-branch.

     
  • Don Porter

    Don Porter - 2012-11-05

    my reading of the comments is that this one is done?
    Setting to Pending.... which will Close unless further comments are posted.

     
  • Don Porter

    Don Porter - 2012-11-05
    • status: open-works-for-me --> pending-works-for-me
     
  • Kevin Walzer

    Kevin Walzer - 2012-11-05
    • status: pending-works-for-me --> closed-works-for-me
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks