#2481 X11 Menus do not open

obsolete: 8.4.19
closed-works-for-me
5
2008-10-03
2008-08-01
No

Greetings,

X11 menus do not open upon a mouse click, if the
menubutton has no text but just an image and if
the menu items are just images.
Affected platforms are MacOSX/X11 _and_
Debian 4.0/X11 with the Gnome desktop (focus follows
mouse must be enabled on the latter!).

The menu can still be opened, when the mouse is clicked
on a neighboring menubutton and then moved (with the
mouse button held down) over the menu that does not
open in the first place.
Disabling focus follows mouse in Gnome also helps.

best regards,
Randolf

Discussion

  • Todd Helfter

    Todd Helfter - 2008-09-02

    Logged In: YES
    user_id=92123
    Originator: NO

    Anyone with access to any of the above platforms want to take ownership of this bug report?
    I've no access to either OSX or Debian systems.
    -Todd

     
  • Donal K. Fellows

    • status: open --> pending-works-for-me
     
  • Donal K. Fellows

    Appears to work for me with HEAD built for X11 on OSX Leopard, but I've only tested with the widget demo. If it needs something else, please supply a test script that gets things in a state where we can check for the problem.

     
  • Randolf Schultz

    Randolf Schultz - 2008-10-03
    • status: pending-works-for-me --> closed-works-for-me
     
  • Randolf Schultz

    Randolf Schultz - 2008-10-03

    Ok, the culprit seemed to be an <Enter> binding on the menubutton, that in turn contained
    an "update" command. This obviously broke the arming of the button in a subtle way.

    kind regards,
    Randolf

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks