#2468 "alt" theme - disabled checkbuttons - no selected feedback

obsolete: 8.5.2
closed-fixed
1
2010-12-07
2008-06-26
Zbigniew
No

Disabled ttk::checkbutton doesn't show the state of associated variable, when using "alt" theme.

Discussion

  • Joe English

    Joe English - 2008-12-28
    • summary: Bug in "alt" theme --> "alt" theme - disabled checkbuttons - no selected feedback
     
  • Joe English

    Joe English - 2008-12-31

    Cause of problem: the color palette computation for IndicatorElements (based on TIP#109 implementation) was wrong. Fixed in CVS: disabled+selected is now visually distinct from disabled+!selected; in addition, check/radiobutton indicators now look like Windows 98 as intended.

     
  • Joe English

    Joe English - 2008-12-31
    • status: open --> closed-fixed
     
  • Don Porter

    Don Porter - 2010-08-10
    • priority: 5 --> 9
    • status: closed-fixed --> open-fixed
     
  • Don Porter

    Don Porter - 2010-08-10

    please backport fix for 8.5.9

     
  • Joe English

    Joe English - 2010-12-07

    Fixed in CVS. Closed. Please leave closed.

     
  • Joe English

    Joe English - 2010-12-07
    • priority: 9 --> 1
    • status: open-fixed --> closed-fixed