Module Browser - CVSRoot read problem

  • AndyR

    AndyR - 2006-08-24

    I have CVSNT server running on a Win2003 machine
    I hage CVSNT client running on my desktop
    I am using TKCVS 8.0.3

    I can use command line from windows shell to perform

    cvs ls -l -R

    and get a listing of all modules and files in modules

    Or I can simply do

    cvs ls

    and just get a list of modules.

    However when I try and use the tkcvs module browser I get

    cvs server:User XXXXXX cannot read CVSROOT

    Now everything else I have tried to do in TkCVS seems to work ok. I can check in modules, check out modules (assuming I know the module name), check in check out files etc.

    Given that the command line listing works I am at least somewhat confident that CVSNT is installed and configured correctly, and that all the permisions are correct.

    Any thoughts?

    What is TKCVS actually doing when I run the module browser? Is there a way to echo the commands it is sending to CVS?

    - Andy R

    • AndyR

      AndyR - 2006-08-28

      A follow up
      Making some progress.
      Have got at least some access but still not sure I have this right.

      My expectation is that when all is configured correctly, if I click on the module/repository browser I will see a listing of all modules that have been created in the repository. Then I can select one an check it out to a local diretory and work on it.

      The Module browser does not give an error now but it seems to be looking in my local home directory for info

      The CVSROOT appears correct

      The Module name/entry is blank

      The current directory is my local home

      Am I misinterpreting what this tool will do?

      I am going to have a lot of users with no CVS experience and need a way for them to see what modules already exist for checkout.


      - Andy R

    • AndyR

      AndyR - 2006-08-28

      At the command line
      after logging using the remote server CVSROOT

      cvs ls
      returns both modules that have been created namely:

      CVSROOT is the module created when the repository was created containing control files
      ESState is my little test directory.

      I would expect the module browser would simply list those two modules as well. Instead it lists nothing.
      Any help is appreciated.

      - Andy R


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks