Error in startup script: invalid command name

Help
tlj
2007-04-17
2013-04-17
  • tlj

    tlj - 2007-04-17

    I am working on an aix5.3 platform.

    I have installed tkcvs_8_0_3 and ActiveTcl8.4.14.0.272572-aix-rs6000

    I the bins for BOTH at the top of my PATH.

    when I run tkcvs I get the following error.  I have done some quick looks but have no idea what/where this is looked for.  What do I need to do to resolve this problem?

    tkcvs
    Error in startup script: invalid command name "::picklist::load"
        while executing
    "::picklist::load"
        (file "/afs/.../TkSVN/install_803/bin/tkcvs" line 96)

     
    • DorothyR

      DorothyR - 2007-04-17

         Did you run doinstall.tcl?

         If yes, make sure you don't have a TCLROOT environment variable
         that's pointing to somewhere other than where it put tkcvs' .tcl
         files.

         If that's not the trouble, do "which tkcvs" or whatever tells you which tkcvs
         file you're executing.  Look at that file and see what TclRoot is set to.
         Are the .tcl files in $TclRoot/tkcvs?  Is there a tclIndex there?

       
      • tlj

        tlj - 2007-04-17

        THANKS -  The first time I ran doinstall.tcl I used tcl 8.3.

        This time I made sure to do doinstall with tcl8.4 and things are looking better now

         

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks