error in startup script

  • john

    john - 2007-08-31

    I am new to TKCVS and after installing it on a Solaris box, I am getting the following error. The command I am running is just tkcvs without any options or additional commands.

    Error in startup script: unknown color name "white"
        (database entry for "-background" in widget "")
        invoked from within
    "::entry $w.e -relief flat -border 0 -textvariable $varName -bg $cvsglb(textbg)"
        (procedure "::picklist::entry" line 10)
        invoked from within
    "::picklist::entry cwd directory"
        (procedure "workdir_setup" line 47)
        invoked from within
        invoked from within
    "if {[string match {mod*} $cvscfg(startwindow)]} {
      wm withdraw .
      foreach {incvs insvn inrcs} [cvsroot_check [pwd]] { break }

      if {$insvn} {
        (file "/usr/local/bin/tkcvs" line 338)

    • DorothyR

      DorothyR - 2007-09-01

      Tk requires a functioning X11 environment.  Yours isn't even finding the rgb.txt file, apparently.  Something is severely mis-configured either on your system or in your environment.  Sorry, you'll have to get that figured out first.

    • john

      john - 2007-09-04

      I do have X11 installed and it is working with other applications without any problems. Does TKCVS look for the rgb.txt in any particular path?

      If I add TCLROOT=/usr/local to my env then the only error I get is the following:

      Error in startup script: invalid command name "::picklist::load"
          while executing
          (file "/usr/local/bin/tkcvs" line 103)

      If I remove the TCLROOT then I get the above error.

      • DorothyR

        DorothyR - 2007-09-04

        That time, I don't think you got far enough to ask for a color.

        Do you have OPENWINHOME set in your environment?  As far as I know it's always been necessary to have OPENWINHOME=/usr/openwin on a Sun, no matter which session manager you're using. 

        As far as I can tell, Tk doesn't access rgb.txt directly.  It uses the X11 API with calls to XVisuaInfo and so on.  The X libs on the machine are supposed to find rgb.txt.  On a Sun, that's $OPENWINHOME/lib/X11/rgb.txt.  On a Solaris 10 machine I have to hand, there are additional symbolic links at /usr/openwin/lib/rgb.txt and /usr/X11/lib/X11/rgb.txt.  I don't think that last one was present on older (pre-Gnome) Solaris versions, though I'm not sure.

        What version of Solaris do you have?  Are you using Gnome or CDE?  With CDE you won't get very far without $OPENWINHOME, but maybe Gnome is different.

    • MickH

      MickH - 2007-11-20

      Has this problem been resolved?

      I have a clean installation of Fedora core 6 and have installed tcl and tk 8.4.13-3 and tkcvs_8_0_4. I get the same error. Any time tkcvs tries to use a name for a colour I get the error. If I replace white with #FFFFFF all is ok (until the next colour).

      Any checks I can make to confirm correct installation?

      • DorothyR

        DorothyR - 2007-11-20

        How did you install tcl/tk?  Did you compile it from the tar.gz distribution, or was it a source or binary rpm?  If it was an rpm, I'd suspect that of being slightly wrong for your system.

        To demonstrate the problem in Tk, you can invoke wish, and when it gives you a % prompt, do something like

        % frame .f -background blue

        That won't tell you much, though.  I really can't help with this.  I can't duplicate it, and I'm not on your machine so I can't examine your X11 installation or your environment.


    • MickH

      MickH - 2007-11-20

      Thanks for the reply.

      As you suspected, when I run the command in wish I get the error "unknown color name blue", so the error is in tk/tcl, not in tkcvs.

      I installed tk and tcl from rpms from the fc6 disk so they ought to be ok.

      Thanks anyway.


    • MickH

      MickH - 2007-11-20

      I found the problem.

      I have 2 machines, 1 running windows and 1 linux but only 1 monitor, keyboard, mouse. I am using tightvnc to access the linux box. When I do this I get all the errors in tk with colour names not being found. If I unplug the monitor keyboard and mouse from my windows box and plug them into the linux box to use in the normal fashion, everything works fine!!

      Not sure why this is but at least I have a workaround.

      Obviously I need to buy another monitor!!



Log in to post a comment.