"'abort' was not declared in thi...

  • Maxmotor

    Maxmotor - 2010-11-02


    I added tinyxml.cpp, tinyxml.h, tinyxmlerror.cpp, tinyxmlparser.cpp, tinystr.cpp, and tinystr.h to a new project (in Eclipse) and tried to compile it. However when doing so I get errors where the assert method is called saying "'abort' was not declared in this scope".

    The abort method seems to be called from assert. Following the code to the abort method we end up in the file "stdlib.h". I've tried including the file but this forces new errors on fopen, fseek and ftell.
    Now I dont really know what to do next. Can you help me out?

    Thank you for your time!

  • Maxmotor

    Maxmotor - 2010-11-02

    If I try to exclude the two lines calling assert the errors on fopen, fseek and ftell appear saying they are not declared.

  • Maxmotor

    Maxmotor - 2010-11-03

    I have now imported the code into Visual Studio 2010 instead of Eclipse and it is now working! I have no idea why it didn't work in Eclipse.


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks