Help save net neutrality! Learn more.
Close

Tinn-R with Rgui (64-bit R version 2.11.1)

A. P.
2010-06-15
2012-09-25
  • A. P.

    A. P. - 2010-06-15

    HI -- I am having problems sending commands to an Rgui connection when using
    the new 64-bit version of R (version 2.11.1). There is no problem at all when
    I use the 32-bit version.

    I am running Windows XP (64-bit Version 5.2) After uninstalling R and Tinn-R,
    I re-installed Tinn-R Version 2.3.5.2 and the 64-bit R Version 2.11.1.

    Now I cannot:
    (a) permanently save the path of my Rgui (or Rterm). I need to re-enter these
    every time I start Tinn-R.
    (b) send commands to be executed in the Rgui (though sending to Rterm works).

    Please help.

     
  • Paulo Eduardo Cardoso

    I'm facing exactly the same problem.
    I'm runnung Tinn-r 2.3.5.2 and R x64 v2.11.1 under Windows Vista Ultimate x64
    (Portuguese)

     
  • pfb

    pfb - 2010-06-28

    Hi,
    I also have this problem, with Tinn-R 2.3.5.2 and R 2.11.1 x64, under Windows
    7 64-bit.
    No Rgui / Rterm path is saved when I exit Tinn-R, and launching Rgui from
    Tinn-R doesn't enable the "Submit selection" buttons.

    I'd be pleased if anyone had a solution :)
    Thanks !

     
  • Anonymous - 2010-06-29

    I am having the same problem with Tinn-R 2.3.5.2 and R 2.11.1 x64 running Win
    7 64 bit. Tinn-R will not save my paths and the communication between Tinn-R
    and Rgui doesn't work. Would greatly appreciate any solution!
    Dave

     
  • j j

    j j - 2010-07-06

    I've got the exact same setup and problem. Someone please help!

     
  • Jason S

    Jason S - 2010-07-08

    Same problem as well. I actually installed the much older version (Tinn-R
    1.17.24) which seems to work fine but loses a lot of the markup features :-(
    hope a solution is available soon!

     
  • Anonymous - 2010-07-11

    Same issue...

     
  • j j

    j j - 2010-07-15

    Installing Tinn-R 1.17.24 solved the issue, good idea! Although, I do feel
    a little like I'm working with stone age tinn-r.

     
  • kaktusinho Constancia

    I've got the same Win 7 64-bit issue with Tinn-R 2.3.5.2 and R 2.11.1 x64. Is
    installing Tinn-R 1.17.24 going to be the final solution?

     
  • rcoder

    rcoder - 2010-07-24

    Hello, try to deactivate the option "always use the latest version" in the
    window where you set the paths to rterm.exe and rgui.exe

     
  • RS

    RS - 2010-08-10

    Under Application options-R-Rgui-Recognition check the “Partial” button for
    the (Type(caption search)) . I am running windows 7 64 bit, the 64 bit version
    of R 2.11.1, and tinn-r 2.3.5.2. I don't know why but it seems to solve the
    problem.

     
  • aaryn

    aaryn - 2010-09-14

    sabaric's suggestion worked for me!

     
  • j j

    j j - 2010-09-15

    This suggestion works! []

     
  • jcfaria

    jcfaria - 2010-09-29

    Hi,

    Sorry, I had only XP and Vista (32 bits), so had no way to detect and fix the
    problem. We purchased 20 new computers for statistical computing laboratory of
    my university, all with windows 7 and 64 bits.

    Soon I will be able to compile Tinn-R under Windows 7 and I believe all
    related problems will be fixed.

    Best,
    JCFaria

     
  • YO32

    YO32 - 2011-02-03

    I solve this issue by just going to the
    option-> application-> R
    I change the path into the 64 bit and also by clicking on the architeture bit
    the 64 bit instead of 32.
    Best
    Yo32

     
  • Anonymous - 2011-04-30

    The solution seems to be easy: don't let Tinn-R look for the newest version:
    "use latest installed version" to "No"
    (then it looks for R:\program files\R\bin, which is always wrong with the
    newer versions of R).
    Best
    Renger

     
  • rsy

    rsy - 2011-11-20

    Thanks, sabaric, for a solution. I've been unable/unwilling to switch to 64-R
    until this fix was posted.
    Many thanks!!

     

Log in to post a comment.