trPaths problem sending more than 1 line

Ana
2011-05-23
2012-09-25
  • Ana

    Ana - 2011-05-23

    Hi everybody.

    I am having a classical "source(.trPaths .." problem with a twist. I can send
    on line of code to R (64-bit R version 2.13.0, Windows 7) but I can not send a
    selection with more than one line.

    I am familiar with the "source(.trPaths .." conflict, and I have successfully
    installed and configured Tinn-R in different computers, versions and colors.
    My Rprofile.site is down here, but as you can see is the usual one. The paths
    are correct. Initially I could not send any code, so I followed the forum
    recommendations (https://sourceforge.net/projects/tinn-r/forums/forum/481900/
    topic/3741784)
    and manage to send one line, but no more.

    Any idea about how to solve it?

    R version 2.13.0 (2011-04-13)
    Platform: x86_64-pc-mingw32/x64 (64-bit)
    OS: Windows 7.

    ===============================================================

    Tinn-R: necessary packages and functions

    Tinn-R: >= 2.2.0.2 with TinnR package >= 1.0.3

    ===============================================================

    Set the URL of the preferred repository, below some examples:

    options(repos='http://software.rc.fas.harvard.edu/mirrors/R/') # USA

    options(repos='[http://cran.ma.imperial.ac.uk/](http://cran.ma.imperial.ac.uk

    /)') # UK

    options(repos='[http://brieger.esalq.usp.br/CRAN/](http://brieger.esalq.usp.b

    r/CRAN/)') # Brazil

    library(utils)

    Check necessary packages

    necessary <- c('TinnR', 'svSocket')
    installed <- necessary %in% installed.packages()
    if (length(necessary) >=1)
    install.packages(necessary)

    Load packages

    library(TinnR)
    library(svSocket)

    Uncoment the two lines below if you want Tinn-R to always start R at start-

    up

    (Observation: check the path of Tinn-R.exe)

    options(IDE='C:/Tinn-R/bin/Tinn-R.exe')

    trStartIDE()

    Set options

    options(use.DDE=T)

    Start DDE

    trDDEInstall()

    .trPaths <- paste(paste(Sys.getenv('APPDATA'), '\Tinn-R\tmp\', sep=''),
    c('', 'search.txt', 'objects.txt', 'file.r', 'selection.r', 'block.r',
    'lines.r'), sep='')

     
  • wanderer

    wanderer - 2011-09-19

    I researched a bit. Everyone seems saying that the problem is because Windows
    sets the temporary folder as read-only.
    Here's my solution:
    1. Check the location of the temporary folder in R using Sys.getenv('APPDATA')
    2. Look for the Tinn-R\tmp\ folder in the place of (1)
    3. Change the read-only properties for the folder
    Done.

     
  • Zenonn87

    Zenonn87 - 2012-03-16

    I have got a solution worked for me. Make the follow steps in Administration
    mode: R -> Configurate -> Permanaent.
    Than delete the # mark from the UK and Brasil repository. Like this:

    ##===============================================================
    ## Tinn-R: necessary packages and functions
    ## Tinn-R: >= 2.2.0.2 with TinnR package >= 1.0.3
    ##===============================================================
    ## Set the URL of the preferred repository, below some examples:
    options(repos='[url]http://software.rc.fas.harvard.edu/mirrors/R/[/url]') # USA
    options(repos='[url]http://cran.ma.imperial.ac.uk/[/url]') # UK
    options(repos='[url]http://brieger.esalq.usp.br/CRAN/[/url]') # Brazil
    

    Run with hand all of the line (not just the the passage quoted above) and it
    should be fine.

    For me it worked. I read a lot of forum about this problem non of them worked
    for me. Tried re-installation, older version, etc. So I thought maybe the
    other repositories will be OK, and they were.

    Good luck with that.

     
  • Anonymous - 2012-05-17

    I don't think you have write access to:

    Sys.getenv('APPDATA')

    My user name is rm1. I added the following line to the start of Rprofile.Site:

    Sys.setenv(APPDATA = "C:/Documents and Settings/rm1/Application Data")

    This is somewhere I can write to, so Tinn-R can do it's thing and write
    'selection.r" for R to interpret.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks