.trPaths Problem on XP and Vista Machines

Adam Carr
2011-01-18
2012-09-25
  • Adam Carr

    Adam Carr - 2011-01-18

    Good Morning:

    I posted a question on Saturday 15 Jan 2011 regarding this problem and it is
    still vexing me. I am running the latest version of Tinn-R (2.3.7.1) and R
    (2.12.1). I am running the packages on a 32 bit Windows XP machine and a 64
    bit Windows Vista machine. Before these versions I ran R 2.12.0 and Tinn-R
    2.3.6.2 without any trouble. When I attempt to send several lines to R-term I
    get the following error: source(.trPaths, echo=TRUE, max.deparse.length=150).
    This is supplemented by the following information in the log file:

    Warning message:
    In getDependencies(pkgs, dependencies, available, lib) :
    package 'svIO' is not available
    done
    Error in loadNamespace(i, c(lib.loc, .libPaths())) :
    there is no package called 'XML'
    Error: package/namespace load failed for 'svIDE'
    Error in source(.trPaths, echo = TRUE, max.deparse.length = 150) :
    object '.trPaths' not found

    I know that my Rprofile.site file is set up correctly on both machines, but I
    get the same error on both. What is causing this? If I manually enter the
    following code into the Tinn-R editor and run it:

    .trPaths <- paste(paste(Sys.getenv('APPDATA'), '\Tinn-R\tmp\', sep=''),
    c('', 'search.txt', 'objects.txt', 'file.r', 'selection.r', 'block.r',
    'lines.r'), sep='')

    I no longer get the error but I did not have to do this with previous Tinn-R
    and R combinations. I made sure the Rprofile.site file contained these lines
    and the trDDEInstall() precursor and all seemed to work well.

    Any advice would be greatly appreciated.

    Adam

     
  • theed

    theed - 2011-03-08

    Hi,

    I had the same problem. It appears to have been a problem of user rights. I
    started Tinn-R as admin. There, I chose the menu point: R -> Configure ->
    Permanent
    Then I restarted with my normal user account, and everything was fine.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks