#49 version 1.19.4.6 does not remember R path

v1.0_(example)
closed
nobody
None
5
2014-01-29
2007-12-20
Anonymous
No

After starting Tinn-R and customizing it like hotkeys etc. All settings are saved but not the R-Path. It is set to

sPathRGui=\bin\Rgui.exe

At the moment I have to reset the path manually every time I start Tinn-R.

Tinn R 1.19.4.6, R 2.6.1, Win XP SP2

Discussion

  • jcfaria

    jcfaria - 2007-12-21

    Logged In: YES
    user_id=1273895
    Originator: NO

    Hello,

    Are you sure that the registry of the OS don't has conflict?
    Do You have more than one version installed?

    I've been using this version (a lot) without any problem under Vista and XP!

    JCFaria

     
  • b. hermicz

    b. hermicz - 2007-12-21

    Logged In: YES
    user_id=1964956
    Originator: NO

    Hello,

    There is more than version of R installed, but this was no problem with some previous Tinn-R version. I am not sure if there is a registry problem. But the path in the registry should be relevant only for the first start of Tinn-R, shouldn't it? Everything that is manually altered like paths, settings like "--sdi" etc. should be saved (I think).

    b hermicz

     
  • Nobody/Anonymous

    Logged In: NO

    I have the same problem with version 1.19.4.7, R 2.6.1, Win XP SP2.
    I can set sPathRGui to C:\Program Files\R\R-2.6.1\bin\RGui.exe, but upon closing and restarting Tinn-R, the "Tinn.ini" file overwrites sPathRGui to \bin\RGui.exe.

    I have no other version of R residing on my computer.

    Please fix. :)

     
  • jcfaria

    jcfaria - 2008-01-16

    Logged In: YES
    user_id=1273895
    Originator: NO

    Hello all,

    It was fixed and will be available in the next version (1.19.4.8).
    For while, the best option is start R outside of Tinn-R.

    All the best,
    JCFaria

     
  • Steve

    Steve - 2008-07-15

    Logged In: YES
    user_id=2147935
    Originator: NO

    Has anyone found a work around for this problem? Alternatively, can you point me to an earlier release of Tinn-R that works correctly?

    Thanks
    Steve_Friedman@nps.gov

     
  • jcfaria

    jcfaria - 2008-07-16

    Logged In: YES
    user_id=1273895
    Originator: NO

    Hello,

    It is a bug and arises if you have more than one version of R installed.
    It was already fixed and will be available in the next version (2.0.0.1)
    to be released.
    One option to contour the problem is always start your preferred R version outside
    of Tinn-R. It will recognizes it without problem.

    HTH,
    JCFaria

     
  • Nobody/Anonymous

    This happens to me also. It started after I updated my version of R to 2.7.0. I have Tinn-R1.19.4.7.

     
  • jcfaria

    jcfaria - 2014-01-29
    • status: open --> closed
    • Group: --> v1.0_(example)
     

Log in to post a comment.