Timidity v2.13.x uses so much CPU.

  • Nobody/Anonymous

    I tested Timidity in Linux.
    It uses CPU of 80 ~ 90%, but v2.11.x only use 30 ~ 40%.
    How can I reduce CPU use?

    used linux version
    Linux 2.4.27 #2 Sat Feb 5 00:05:26 KST 2005 i686 i686 i386 GNU/Linux

    • Dieter Demerre

      Dieter Demerre - 2006-04-13

      When using timidity to CONVERT files (NOT LISTENING in REAL TIME), you can make timidity use less CPU (but it will run slower :D) using "nice" (read man nice)


      nice -n 15 timidity -Ow myfile.mid -o out.wav

      Which is no solution, I know, if you're running timidity in on-line mode (listening directly i.s.o. converting).

    • Nobody/Anonymous

      2.13.x uses more CPU, because the default playing quality has been increased. Just use switches to decrease the default, e.g.: turning off reverb with -EFreverb=d, Turn off resampling with -EFresamp=d, decrease sampling frequency with -s, etc. timidity -h will show the possible options.


Log in to post a comment.