Me again....

As a bit of an update, I have put my wampserver/tikiwiki combo online (within the company intranet) and connected to  the server from another PC in the network using my server PCs Hostname (as given by ipconfig) and the tiki homepage appears :o)

but when I log in and hit the page edit button, which was previously adding in an extra back and fore slash on my localhost, the URL now does not contain the hostname.
for example

http://mydesktophostname/tiki-index.php  ->works
go to edit a page -> URL of button is:
http://tiki-editpage.php?page=HomePage ->mydesktophostname has gone :o(

Is this a relative Vs absolute URL forming bug? or have I set up my server and virtual hosts wrong?

Anybody?

Martin.

On Mon, Aug 10, 2009 at 12:14 PM, Martin Dale <martin.dale.1@gmail.com> wrote:
Gary,

When I use http://localhost/tikiwiki-3.1 it all works too.  The problem only appears when I use the virtualhost of http://my_tiki and click on an buton within a <div id="page-bar"> area.

The reason I want this is because I'm planning on opening up my tiki on the company intranet and thus "localhost" won't work for anyone else.

Martin


On Mon, Aug 10, 2009 at 10:44 AM, Gary Cunningham-Lee <gary_c@cunningham-lee.com> wrote:
Hi,

I also use wampserver (on windows xp) for testing locally, but connect
using urls like http://localhost/TikiWiki/trunk... and the urls are
fine. So maybe the extra slashes could be due to the virtual host - just
a guess based on the differences in our setups; I don't know what other
variables might be involved.

-- Gary

Martin Dale wrote:
> Hi,
>
> I've just installed tiki3.1 on my local machine (running wampserver).
> I have set up a subfolder for the tiki within my www folder and
> created a virtual host to point to it.
>
> see here:
> <VirtualHost *:80>
>     ServerAdmin me@jmydomain.com <mailto:me@jmydomain.com>
>     DocumentRoot "C:/Martin/MyCodedev/wamp/www/tikiwiki-3.1"
>     ServerName www.my_tiki.com <http://www.my_tiki.com>
>     ServerAlias my_tiki.com <http://my_tiki.com> my_tiki
>     ErrorLog "C:/Martin/MyCodedev/wamp/www/tikiwiki-3.1/logs/error.log"
>     CustomLog
> "C:/Martin/MyCodedev/wamp/www/tikiwiki-3.1/logs/access.log" common
> </VirtualHost>
>
> and in my windows/system32/drivers/etc/hosts file I have
> 127.0.0.1       localhost
> 127.0.0.1   my_tiki
>
> Thus when I type in the url http://my_tiki I get redirected to
> http://my_tiki/tiki-index.php and it looks good but when I click on
> the edit, or source or any of the page buttons the url points to
> http://my_tiki/\/tiki-editpage.php?page=HomePage *->NOTE THE EXTRA
> "\/"* (backslash followed by foreward slash)
>
> Why is this?  How do I fix it.  If I delete the "\/" it works so there
> is something that is this into the url.
>
> Any help would be much appreciated.
>
> Martin
>
> ------------------------------------------------------------------------
>
> ------------------------------------------------------------------------------
> Let Crystal Reports handle the reporting - Free Crystal Reports 2008 30-Day
> trial. Simplify your report design, integration and deployment - and focus on
> what you do best, core application coding. Discover what's new with
> Crystal Reports now.  http://p.sf.net/sfu/bobj-july
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> Tikiwiki-users mailing list
> Tikiwiki-users@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/tikiwiki-users
>
> ------------------------------------------------------------------------
>
>
> No virus found in this incoming message.
> Checked by AVG - www.avg.com
> Version: 8.5.392 / Virus Database: 270.13.49/2293 - Release Date: 08/09/09 18:10:00
>


------------------------------------------------------------------------------
Let Crystal Reports handle the reporting - Free Crystal Reports 2008 30-Day
trial. Simplify your report design, integration and deployment - and focus on
what you do best, core application coding. Discover what's new with
Crystal Reports now.  http://p.sf.net/sfu/bobj-july
_______________________________________________
Tikiwiki-users mailing list
Tikiwiki-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/tikiwiki-users