#840 File Gallery: PHP error in "Listing Gallery"

v1.7.3
closed-fixed
nobody
PHP Error (166)
4
2004-01-28
2003-09-23
No

In "Listing Gallery" page, when I pushed "X (remove)"
button without any selection, PHP shows minor warning
messages:

Warning: Undefined index: file in
/usr/local/apache2/htdocs/tikiwiki/tiki-list_file_gallery.php
on line 64

Warning: Argument to array_values() should be an array
in
/usr/local/apache2/htdocs/tikiwiki/tiki-list_file_gallery.php
on line 64

Warning: Invalid argument supplied for foreach() in
/usr/local/apache2/htdocs/tikiwiki/tiki-list_file_gallery.php
on line 64

Discussion

  • Philippe Cloutier

    • labels: 544454 --> PHP Error
    • priority: 5 --> 2
    • milestone: 316038 --> 337037
     
  • Philippe Cloutier

    Logged In: YES
    user_id=738765

    I got the same thing at first attempt.
    Let's consider this as an ordinary bug, priority 2?
    I reported this on FileGalleryDev.

    Thank you.

     
  • Dennis Daniels

    Dennis Daniels - 2003-10-21
    • summary: File Gallery: PHP error in "Listing Gallery" --> File Gallery: PHP error in "Listing Gallery"
     
  • Kentaro Fukuchi

    Kentaro Fukuchi - 2003-10-22

    Logged In: YES
    user_id=157663

    I have tested the latest from CVS and reproduced the same bug.
    What I did are:
    1) Install Tiki 1.8 HEAD
    2) Enabled File Gallery
    3) Create a Gallery
    4) Get a list of the Gallery
    5) Just pressed "X"(remove) button
    6) Got warnings.

    I used PHP4.1.2 and MySQL-4.0.13. PHP4 was used as CGI,
    not a module.

     
  • Dennis Daniels

    Dennis Daniels - 2003-10-22
    • priority: 2 --> 4
    • milestone: 337037 --> 316038
     
  • Dennis Daniels

    Dennis Daniels - 2003-10-22

    Logged In: YES
    user_id=403318

    Thanks Fukuchi for the update! I've upgraded the severity
    and changed the bug to CVS! It's help like yours that makes
    OS work!
    thanks again!
    dgd

     
  • Philippe Cloutier

    Logged In: YES
    user_id=738765

    This is in Tiki 1.7.3.
    I question the priority of this bug (let's remember this is
    admin-only, error message only, and almost never happens)
    but anyway, it doesn't mind for a single bug.
    Also let's keep the group to latest bugged stable version
    (we'll filter CVS stuff in our future Doc search areas when
    SF finally improve their search [this fall...to see!]).
    Anyway thank you fukuchi.

     
  • Philippe Cloutier

    • milestone: 316038 --> v1.7.3
    • status: open --> open-accepted
     
  • Philippe Cloutier

    Logged In: YES
    user_id=738765

    This seems to be fixed on 1.7.5/1.8CVS so I removed it from
    FileGalleryDev.

     
  • Philippe Cloutier

    • status: open-accepted --> closed-fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks