#1884 File Gallery Permissions not functioning as expected

v1.8.4.1
closed
nobody
5
2005-03-16
2005-02-18
No

Hi - I'm struggling with File Galleries and permissions.
I have the following groups:
Anonymous (don't want them to see file galleries)
Registered (want them to see file galleries, download
files, upload files, create file galleries, but not delete file
galleries created by other users)
Editors (as registered)
Admin (can do everything).

I assign the following permissions to the Registered
group:
tiki_p_create_file_galleries
tiki_p_upload_files
tiki_p_download_files
tiki_p_view_file_gallery

So, as a Registered user can create a file gallery
('Gallery is visible to non-admin users?' is checked).
However it does not appear in the File Gallery list and
when they click 'upload a file' they get the
message 'You have to create a gallery first!'

However an Admin can see the gallery in the list. If I
give Registered and Editors group the
tiki_p_admin_file_galleries permission they can see the
galleries in the list and use them. However, they can
also delete galleries - I only want admins to delete
Gallaries, and Reg / Eds to delete a gallery that they
have created.

I do not think I should have to assign
tiki_p_admin_file_galleries to all user groups (especially
as that gives some groups priviledges not appropriate
for them) in order for file galleries to be listed.

Discussion

  • Anonymous - 2005-02-19

    Logged In: YES
    user_id=993086

    Seem to have the same proble with Image Galleries as well.

     
  • gnutritious

    gnutritious - 2005-03-15

    Logged In: YES
    user_id=1220286

    I'm on 1.8.5, and having the same problem. Any solution?
    Thanks!

     
  • Anonymous - 2005-03-15

    Logged In: YES
    user_id=993086

    I'm now on 1.8.5 (haven't retested this yet, but would assume
    the same problem) - I've not found a solution yet...

     
  • bertrand Gugger

    bertrand Gugger - 2005-03-16
    • status: open --> closed
     
  • bertrand Gugger

    bertrand Gugger - 2005-03-16

    Logged In: YES
    user_id=379264

    That is corrected in branch 1.8 cvs (tiki-file_galleries.tpl)
    to lines to delete:
    42d41
    < {if $tiki_p_admin_file_galleries eq 'y'}
    44d42
    < {/if}
    The issue does not exist for image gallerie 1.8.5.
    Anyway you should upgrade to 1.8.5, it's painless (same DB)
    and much more secure.

     
  • Anonymous - 2005-04-01

    Logged In: YES
    user_id=993086

    Thanks - that has fixed it.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks