#1847 Mail-in:Cant find user from email address

v1.8.4.1
open-remind
5
2005-01-23
2005-01-21
No

I am running Outlook 2003 on Windows XP SP2.
When I try to use GET:pagename on my 1.8.4.1 site, the
mail-in feature sent back a message saying I cant use
that feature (I have turned anonymous useage off).
I double checked my email address was set in Admin/Users.
After much debugging it looks like the address
$aux["sender"]["email"] which is passed to
get_user_by_email had trailing chars "\n\r" which was
stopping the db lookup from working.
I changed the line in tiki-mailin-code.php from:
$aux["sender"]["user"] =
$userlib->get_user_by_email($aux["sender"]["email"]);

to:

$aux["sender"]["user"] =
$userlib->get_user_by_email(trim($aux["sender"]["email"]));

which fixed the problem.

Discussion

  • Damian Parker

    Damian Parker - 2005-01-21
    • assigned_to: nobody --> damosoft
    • status: open --> pending-remind
     
  • Damian Parker

    Damian Parker - 2005-01-21

    Logged In: YES
    user_id=458483

    Please upgrade to 1.8.5 and apply the latest security
    patches. 1.8.4 and 1.8.4.1 are NOT secure.

    Thanks

     
  • Russell Penney

    Russell Penney - 2005-01-23
    • status: pending-remind --> open-remind
     
  • Russell Penney

    Russell Penney - 2005-01-23

    Logged In: YES
    user_id=1201582

    This problem does NOT go away because of the version. I know
    1.8.4.1 is not secure. This bug has nothing to do with that
    and is still evident in 1.9

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks