#1646 New Forum posts cause CommentsLib.php errors

v1.8
closed-out-of-date
nobody
None
5
2004-09-10
2004-09-09
Rob Kelley
No

My 1.8 installation was trying to process some messages
in a pop3 account. At first, any attempt to view the
forum (in Firefox) just hung (the page stops waiting
for the website and says done without leaving the old
page).

Finally, through IE and a different session ID (might
just be because I waited a couple minutes), I get these
error messages:

Warning: Cannot use a scalar value as an array in
/home/rkelley/public_html/wiki/lib/commentslib.php on
line 245
Notice: Undefined index: message-id in
/home/rkelley/public_html/wiki/lib/commentslib.php on
line 276
Notice: Undefined index: message-id in
/home/rkelley/public_html/wiki/lib/commentslib.php on
line 277
Warning: Cannot use a scalar value as an array in
/home/rkelley/public_html/wiki/lib/commentslib.php on
line 245
Notice: Undefined index: message-id in
/home/rkelley/public_html/wiki/lib/commentslib.php on
line 276
Notice: Undefined index: message-id in
/home/rkelley/public_html/wiki/lib/commentslib.php on
line 277

Two new topics appear on the page. One has no subject
line but does have the body of the email. The other is
a duplicate of the first with the subject line and all
the replies to it. When I click through to the topic
page, the same error messages above appear. For what
it's worth, this is the subject line of the originating
email:

[nycwireless] Does anyone use Apple's Airtunes Service?

Any ideas?

Thanks!

Rob

Discussion

  • Philippe Cloutier

    Logged In: YES
    user_id=738765

    1.8 what? Make sure to use at least 1.8.4. You can indicate
    your version in the "group" field.

     
  • Rob Kelley

    Rob Kelley - 2004-09-09
    • milestone: --> v1.8
     
  • Rob Kelley

    Rob Kelley - 2004-09-09

    Logged In: YES
    user_id=466494

    My installation came through an ISP using CPanel/Fantastico.

    It just says 1.8 --Polaris-- .

     
  • Philippe Cloutier

    Logged In: YES
    user_id=738765

    OK you have 1.8.0 then. I don't think this is very relevant
    now that there's been a fix in POP3.

     
  • Damian Parker

    Damian Parker - 2004-09-10
    • status: open --> closed-out-of-date
     
  • Damian Parker

    Damian Parker - 2004-09-10

    Logged In: YES
    user_id=458483

    The Fantastico installation is very very problematic and
    since 1.8.4 is now out Id suggest that you upgrade and even
    perform a fresh installation of the code and just copy the
    db/local.php over. Fantastico installation has caused many
    problems, there are many posts in the tikiwiki.org forums
    about it.

    Im closing this until you have tested with the latest code.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks