#1632 Raw HTML outputted when using search

All_versions
open-accepted
nobody
5
2004-09-03
2004-09-02
teedog
No

See this for an example:
http://tikiwiki.org/tiki-searchindex.php?highlight=blah+a&where=articles&search=go

The search terms are "blah a".

It appears that a search word or words followed by a
single character like a, b, etc. results in gibberish like:
Found "an
style="color:black;background-color:#ffff66;">blahan>
a" in 2 articles

I'm not exactly sure what is special about "a" and "b".
Perhaps they are characeters that appear in the HTML
code? "blah z" does not give the same gibberish
output, perhaps because z doesn't appear in HTML? Just
a completely random guess.

Discussion

  • Philippe Cloutier

    Logged In: YES
    user_id=738765

    Note that for short words Tiki seems to quickly get out of
    memory. Test string "a k" proved particularly harmful,
    bringing doc.tw.o out of memory as well my local 1.8 CVS,
    and it more strangely apparently kills all my Tikis on
    Apache 1.3.31 until Apache is restarted (but PHP still
    works(???)).
    Note that with a last test of searching "a k" this time on
    1.9 CVS PHP survived and I got the attached extremely not
    pretty result which would point to a problem in
    outputfilter.highlight.php.

     
  • Philippe Cloutier

    • milestone: 410992 --> All_versions
    • summary: Raw HTML outputted on search results page --> Raw HTML outputted when using search
    • status: open --> open-accepted
     
  • Philippe Cloutier

    Logged In: YES
    user_id=738765

    Sorry, it's too big, it may stay available for some time on
    ido.ath.cx/tiki-searchindex.php.html (nothing really precious).

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks