#1374 File gallery not using database and wiki image caching

v1.8
open-works-for-me
nobody
5
2004-05-16
2004-03-12
No

General admin:
"Use cache for external images" is checked.

File Gallery admin:
"Use database to store images" is not selected.

Image Gallery admin:
"Use database to store images" is selected.

Create a wiki page containing the content {img
url="http://terris.com/images/cart.gif} and save the page.

You will get an error in imagegallib.php about $tmpDir
not being defined near line 1332.

There are two problems. The first one is that the file
gallery seems to have issues using the file system.

The second problem is that this happened when I changed
the file gallery to use the filesystem instead of the
database. It's odd that the image gallery logic was
affected by this. The image cache logic must be
looking at the file gallery flag ($fgal_use_db) instead
of the image gallery flag ($gal_use_db).

Discussion

  • Philippe Cloutier

    • status: open --> open-works-for-me
     
  • Philippe Cloutier

    Logged In: YES
    user_id=738765

    hi Terris,
    I don't understand what you're reporting.
    Were you actually talking about
    {img src=http://localhost/18/show_image.php?id=7}
    ? If yes, it seems I can't reproduce.

     
  • Terris Linenbach

    Logged In: YES
    user_id=155319

    It doesn't matter which image URL you use. The problem
    happens when a wiki page contains an image and Tiki has been
    configured to cache images, and the file gallery uses the
    filesystem instead of the database.

    Are your config settings as follows:

    General admin:
    "Use cache for external images" is checked.

    File Gallery admin:
    "Use database to store images" is not selected.

    Image Gallery admin:
    "Use database to store images" is selected.

    ?

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks