#1133 DB install inserts create incorrect links for Menu.

v1.8RC
closed-fixed
5
2004-01-08
2003-12-24
Ben
No

In 1-8 BRANCH and possibly others...

I have notices at least 2 cases already where
tiki_1.7to1.8.sql inserts that build the Main Menu links
have the incorrect name for php files.

In other words, A few main menu links are bad.

In both cases there is and "s" in the file name in the sql
where the actual file name does not have an "s"

These are the 2 issues I've noticed so far in
tiki_1.7to1.8.sql

tiki-forums_rankings.php (insert option) should be
tiki-forum_rankings.php (actual file name)

and

tiki-articles_types.php (insert option) should be
tiki-article_types.php (actual file name)

There could be other similar problems in other tiki
versions and also other cases where the plurals/ s's are
incorrect.

There should be a guideline if not already about using
such plurals in file names.

Xenafasa

Discussion

  • Ben

    Ben - 2003-12-24

    Logged In: YES
    user_id=823482

    The categories link in the Menu is broken too.
    it links to tiki-categories.php which does not exist

     
  • Adam Shantz

    Adam Shantz - 2003-12-24

    Logged In: YES
    user_id=786280

    I took care of the two problems reported above & patched
    tiki_1.7to1.8.sql

     
  • Adam Shantz

    Adam Shantz - 2003-12-24
    • assigned_to: nobody --> musus
    • status: open --> closed-fixed
     
  • Adam Shantz

    Adam Shantz - 2003-12-25
    • status: closed-fixed --> open-accepted
     
  • Adam Shantz

    Adam Shantz - 2003-12-25

    Logged In: YES
    user_id=786280

    Changing status back to open because I corrected the file
    the "wrong" way (I've rolled the file back to the previous
    version in cvs). I plan on correcting it the "right" way
    shortly. If someone feels like doing it before I get to it,
    feel free. Otherwise, I'll update this when things are
    fixed. :)

     
  • Philippe Cloutier

    • status: open-accepted --> closed-fixed
     
  • Philippe Cloutier

    Logged In: YES
    user_id=738765

    If I'm not dumb this should be fixed the correct way now :)

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks