The proposed changes has been described in more detail on the issue:
Basically, it removes the time-fields from Period, and extends the
usabaility of Duration without changing its underlying nature or class
names. This is a simplification that seems beneficial in the codebase.
Javdoc for (most of) the proposed change is here: