#21 ./autogen.sh fails on ubuntu 8.10

closed-fixed
nobody
None
5
2009-01-10
2008-12-31
No

I see this when running ./autogen.sh:

***** Checking automake version: 1.10.1
***** Checking autoconf version: 2.61
====================================================================
Running aclocal...
====================================================================
acinclude.m4:1180: the serial number must appear before any macro definition
acinclude.m4:1620: the serial number must appear before any macro definition
acinclude.m4:1982: the serial number must appear before any macro definition
acinclude.m4:2076: the serial number must appear before any macro definition
/usr/bin/m4:configure.ac:19: recursion limit of 1024 exceeded, use -L<N> to change it
autom4te: /usr/bin/m4 failed with exit status: 1
aclocal: autom4te failed with exit status: 1
aclocal failed!
--

the configure.ac:19 line is AC_PROG_LIBTOOL.
My version of libtool is 2.2.4.

If a specific version of libtool is required, please state/enforce it. Also I am running m4 1.4.11.

Discussion

  • Tim Müller

    Tim Müller - 2009-01-10

    This is (hopefully) fixed in SVN now:

    2009-01-10 Tim-Philipp Müller <tim at centricular dot net>

    * configure.ac:
    Use AC_CONFIG_MACRO_DIR, so libtoolize knows where to put the
    .m4 files.

    * macros/ltoptions.m4:
    * macros/ltsugar.m4:
    * macros/ltversion.m4:
    Looks like we shouldn't be shipping these files, they seem to break
    things whenever the libtool version is updated. libtoolize will
    put them here for us.

    If not, please re-open the bug, thanks!

     
  • Tim Müller

    Tim Müller - 2009-01-10
    • status: open --> closed-fixed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks