Cannot use the internal document viewer any more

TXS - Help
Tricolore
2013-04-26
2013-04-30
  • Tricolore

    Tricolore - 2013-04-26

    Today when I tried to view the pdf document (by pressing F7) I had just compiled I got the following error:

    Error: Could not start the command: "C:\Documents and Settings\a3579\Local Settings\Application Data\Programs\MiKTeX\miktex\bin\yap.exe" -1 -s 1c:ame "C:\Work\master_thesis\Document\Report\Report.dvi"

    Pressing F7 to view the document worked last time I used it, which was one or two weeks ago. Looking in "C:\Documents and Settings\a3579\Local Settings\Application Data\Programs", there isn't even a folder called MiKTeX (not even a hidden one); however, there is a MiKTeX folder in the "Application Data" folder, but no yap binary exists there.

    Also, there isn't even any Report.dvi at that location, in fact there isn't any dvi files at all at that location, so I'm confused about why TeXstudio is trying to open a dvi file when I press F7 when there isn't any dvi file at that location (TeXstudio's internal document viewer has always used the pdf file before).

    So what has happened here? Has TeXstudio secretly changed its behvaior when pressing performing this action (F7) since viewing the document has suddenly stopped working (and that yap.exe has never existed at that location), or is it more likely that yap.exe has previously existed there but has now been removed (but then I don't understand why it would take a non-existing file as an argument)?

     
  • Jan  Sundermeyer

    Jan Sundermeyer - 2013-04-26

    you have set txs to use the dvi viewer.
    Easiest solution is to delete texstudio.ini to restore default settings.

     
  • Tricolore

    Tricolore - 2013-04-30

    I haven't set TeXstudio to use any viewer, as far as I'm concerned, so don't understand why TeXstudio tried to use the dvi viewer? Maybe I changed it without realizing it.

    Anyway, I was able to locate texstudio.ini in <my user folder>/Application Data/texstudio, and deleting it worked. Thanks. I made a backup copy of it in order not to loose any commands that I had changed manually.

     
    Last edit: Tricolore 2013-04-30
  • Tricolore

    Tricolore - 2013-04-30

    By the way, as an answer to my own question; it is possible that I have earlier installed MiKTeX in my user folder since I wanted to use it but didn't have admin rights, but now it is installed in the Program Files folder for all users to use and there is no installation in my user folder.

    I haven't uninstalled MiKTeX from my user folder recently, so it's strange that viewing the compiled document has stopped to work just recently (maybe someone else with admin rights did it for me). Anyway, deleting texstudio.ini solved the problems.

     
  • Tricolore

    Tricolore - 2013-04-30

    As a follow-up question, if the MiKTeX bin folder is added to PATH, will TeXstudio use the relative paths to the MiKTeX binaries when compiling texstudio.ini (i.e. "yap.exe", not "<MiKTeX folder>/yap.exe")? If it does, it won't be affected by a re-installation of MiKTeX to another folder (as long as the new bin folder is also added to PATH). (I know it doesn't change the paths once texstudio.ini has been compiled, since I had this problem.)

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks