How to disable Alt+Shift switching to menubar in TeXstudio?

TXS - Help
alpro
2013-12-31
2014-04-01
  • alpro

    alpro - 2013-12-31

    I'm using Alt+Shift for layout switching, so using multiple layouts is problematically in TexStudio (when press alt+shift, application switches to menubar and pressing again alt+shift switches back to text with previously layout... so necessary use mouse for switching to text).

    I'm using Ubuntu 13.10 (KDE4 desktop environment, but this problem was in Unity DE (Ubuntu 13.04)).

    In other applications (including Qt Apps, e.g. JuffEd) this problem doesn't appear.

    UPD: Now the same question but in relation to shortcut "Alt".

     
    Last edit: alpro 2014-01-02
    • Jan  Sundermeyer

      Jan Sundermeyer - 2014-01-01

      This behaviour is imposed by the window manager, see there.

      On 31.12.2013 16:00, alpro wrote:

      I'm using Alt+Shift for layout switching, so using multiple layouts is
      problematically in TexStudio (when press alt+shift, application switches
      to menubar and pressing again alt+shift switches back to text with
      previously layout... so necessary use mouse for switching to text).

      I'm using Ubuntu 13.10 (KDE4 desktop environment, but this problem was
      in Unity DE (Ubuntu 13.04)).


      How to disable Alt+Shift switching to menubar in TeXstudio?
      https://sourceforge.net/p/texstudio/discussion/907840/thread/e5031d12/?limit=50#7ae7


      Sent from sourceforge.net because you indicated interest in
      https://sourceforge.net/p/texstudio/discussion/907840/

      To unsubscribe from further messages, please visit
      https://sourceforge.net/auth/subscriptions/

       
  • alpro

    alpro - 2014-01-02

    Now this problem suddenly is disappeared... But I don't know how (I didn't change application or system settings); I was typing in TeXstudio almost continuously, so application wasn't even restarted...

    Jan Sundermeyer, thanks for reply.
    Now in Settings -> Window Behaviour I clear shortcut "All Windows: Reverse" (was Alt+Shift+Tab), so let us see what will happen.

     
    Last edit: alpro 2014-01-02
  • alpro

    alpro - 2014-01-02

    Can I disable Alt key as switcher to menubar?

     
    Last edit: alpro 2014-01-02
  • Tim Hoffmann

    Tim Hoffmann - 2014-01-02

    This is also handled by the window manager.

     
  • alpro

    alpro - 2014-01-03

    There (https://forum.kde.org/viewtopic.php?f=111&t=119019) they say that in my case this problem only with concrete TeXstudio application (I didn't find other KDE/Qt applications with the same problem)...

     
  • Jan  Sundermeyer

    Jan Sundermeyer - 2014-01-03

    does not do so here (alt+shift , Kubuntu 12.04)

     
  • Tim Hoffmann

    Tim Hoffmann - 2014-01-03

    Which settings are you using for

    Preferences -> General -> Appearance -> Style
    and
    Preferences -> General -> Appearance -> Color Scheme

    You can try different combinations of the above settings. Does it happen with all of them?

     
  • alpro

    alpro - 2014-04-01

    I have the same problem in Cinnamon desktop environment (Linux Mint).
    Sometimes when I press Alt+Shift (layout switching), the input cursor is blocked and if then I press arrow (up/down, left/right) — the menubar item is opened; so I can switch back to input cursor only by Esc pressing.

     
    Last edit: alpro 2014-04-01

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks