set spell check to ignore text in comments, math, etc.

TXS - Help
Frank
2013-11-17
2014-08-29
  • Frank

    Frank - 2013-11-17

    I see in the manual/changelog, that the spell checker will not look inside \ref{} and some other commands. Is it possible to customize this behavior?

    For example, I would like it to ignore $X_{ito}$ entirely, instead of warning me about "ito". Similarly, I like to abbreviate words in my comments, and don't need these 'misspellings' corrected.

    I'm using 2.6.2 in a Dropbox.

    Thanks,

    Frank

     
  • isigm

    isigm - 2014-08-29

    I have the same question! did you find any answer yet?

     
    • Denis Bitouzé

      Denis Bitouzé - 2014-08-29

      Le ven. 29 août 2014 à 12h48, "isigm" boboislav@users.sf.net a écrit :

      I have the same question! did you find any answer yet?

      It probably doesn't answer the question but:

      ╭────
      │ $X_{ito}$
      ╰────

      is very bad from a LaTeX point of view: "X" is not indexed by the word "ito" but by the product of the 3 variables "i", "t" and "o". The above math formula should be:

      ╭────
      │ $X_{\text{ito}}$
      ╰────

      (amsmath package or, better, mathtools package is needed).

      Denis

       
      Last edit: Denis Bitouzé 2014-08-29
  • Tim Hoffmann

    Tim Hoffmann - 2014-08-29

    When you have the advanced options enabled, you will find an option "Hide spelling errors in non-text environments" in the "Editor" section.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks