Auto completion for personal commands

TXS - Help
Thiago
2013-04-02
2013-04-04
  • Thiago

    Thiago - 2013-04-02

    I have a style file with personal command \alerta{arg} and I created a cwl file on ~/.config/texstudio which contains \alerta{arg}.

    But this command is now shown on the list when I start typing it.

    Any help?

     
    • Jan  Sundermeyer

      Jan Sundermeyer - 2013-04-03

      do you use package (\usepackage) which has the name of your cwl file ?
      Otherwise you have to activate it manually in the options.

      On 03.04.2013 01:56, Thiago wrote:

      I have a style file with personal command |\alerta{arg}| and I created
      a cwl file on ~/.config/texstudio which contains |\alerta{arg}|.

      But this command is now shown on the list when I start typing it.

      Any help?
      

      Auto completion for personal commands
      https://sourceforge.net/p/texstudio/discussion/907840/thread/520e2300/?limit=25#fc5e


      Sent from sourceforge.net because you indicated interest in
      https://sourceforge.net/p/texstudio/discussion/907840/

      To unsubscribe from further messages, please visit
      https://sourceforge.net/auth/subscriptions/

       
      • Thiago

        Thiago - 2013-04-04

        Yes, my sty file has the same name as the cwl file. I tried selecting it on the completion options and nothing works. Then I tried deselecting it and agains, nothing happens.

        I don't know if this is the reason but my sty file contains the command \alerta{} defined by \newcommand instead of \def or \let.

        Is this the problem?

        ps: my sty file is on /usr/local/texlive/texmf-local/tex/latex/local

        edit
        I found the problem. On cwl file I was using \alerta{arg}#S but the right way is to use without #S.

        Now it works. Thanks.

         
        Last edit: Thiago 2013-04-04

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks