SlikSVN not working

TXS - Help
  • Alair Krenz

    Alair Krenz - 2012-02-14


    I tried to add the SVN ability to my updated TeXstudio 2.3 (Win XP). So I
    installed SlikSVN (in a virtual machine and copied the 'bin' folder to my
    programs-folder) and put the both paths to TeXstudio. When I go to "File ->
    SVN -> check in" I get the error message

    svn: E155007: »C:\textest\test.tex« ist keine Arbeitskopie 
    Prozeß endete mit Fehler(n)

    In english this must be something like:

    svn: E155007: »C:\textest\test.tex« is no wokingcopy
    Process stops with error(s)

    Can someone please help me an tell me what I have to do.

    Notice: This is a crosspost. See:

  • Jan  Sundermeyer

    Jan Sundermeyer - 2012-02-15

    your problem is that test.tex is not a part of a repository.
    txs automatically creates one (and adds the file !) if you use checkin on save
    Otherwise you have to do it yourself.
    Maybe i should add that functionality to the checkin command as well ...
    (how to create a repository is described on the internet ...)

  • Alair Krenz

    Alair Krenz - 2012-02-15

    Hello jsundermeyer,

    thans for your quick answer, but SlikSVN is still not working. I created a
    repository with the command

    svnadmin.exe create "D:\Eigene Dateien\aaa\repos"

    This worked fine. It created folders (and files) like:
    - conf
    - db
    - hooks
    - locks
    and some subfolders.

    I also use the two options:
    - Automatically check in after save
    - Uses SVN revisions to undo before last saved version

    The both paths to svn.exe and svnadmin.exe are correct, but I still get the
    error messages from above when I send 'CTRL+S" (save file).

    I use TeXstudio 2.3 (portable (USB) version) and I installed SlikSVN in a
    sandbox and copied the whole 'bin' folder from the sandbox (creating the
    repository worked, so the svnadmin.exe and the svn.exe work fine) out of the

    Can you please help me a bit more?

  • ghostbones

    ghostbones - 2012-04-22


    i had the same problem and it is only working, if there is no space in your
    filepath. If you make a new latex file, save it for example under
    (C:\latexfiles\test.txt") then you will have another folder created in this
    directory called repo and everything is working fine :)


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks