AW: [texstudio:discussion] How to disable on-the-fly installation dialog when opening a document?

TXS - Help
U_Fischer
2013-11-07
2013-11-07
  • the parser tries to read the package by running latex and stupid miktex suggests to install it, though it is run in non-interactive mode. 
    you can put a cwl named bg.cwl where texstudio.ini is stored to stop the parser.llU_Fischer u_fischer@users.sf.net hat geschrieben:I created this example document in an external editor:

    \documentclass{article}
    \usepackage{bg}
    \begin{document}
    blub
    \end{document}
    When I open it in texstudio the miktex installation dialog pops up and asks me if I want to install the backammon package (I have set the on-the-fly to "ask me first"). If I close the file and reopen it the dialog doesn't appear again. But closing texstudio and reopen it triggers it again. The setting in "Editor / Interaktives Überprüfen / Paket" (no idea how it is called in english) does not change the behaviour.

    Ulrike Fischer

    How to disable on-the-fly installation dialog when opening a document?

    Sent from sourceforge.net because you indicated interest in https://sourceforge.net/p/texstudio/discussion/907840/

    To unsubscribe from further messages, please visit https://sourceforge.net/auth/subscriptions/

     
    • U_Fischer
      U_Fischer
      2013-11-07

      Well creating a bg.cwl is not an option. This was only an example: I often get files from other people and I can't know which packages will be loaded without looking at the file. I ran into the problem when I tried to open my test file in texstudio. That's a jungle of 3000 lines with code snippets and small documents. texstudio triggered the installation dialog for 20 packages all of them way behind a \end{document} command and so currently irrelevant.

      I don't know why texstudio needs to run latex on the packages (and how it decides which engine to use and what happens if a package is not there or gives errors), but I would really prefer if I could trigger such an analyze manually so that I can inspect the file first.

      At least you should add the --disable-installer option to the latex call when miktex is used so that the installation routine is not called.

      Ulrike Fischer

       
      • What does miktex give as a result for kpsewhich bm.sty ?
        It is supposed to be empty, if the package is not installed ...

        On 07.11.2013 09:50, U_Fischer wrote:

        Well creating a bg.cwl is not an option. This was only an example: I
        often get files from other people and I can't know which packages will
        be loaded without looking at the file. I ran into the problem when I
        tried to open my test file in texstudio. That's a jungle of 3000 lines
        with code snippets and small documents. texstudio triggered the
        installation dialog for 20 packages all of them way behind a
        \end{document} command and so currently irrelevant.

        I don't know why texstudio needs to run latex on the packages (and how
        it decides which engine to use and what happens if a package is not
        there or gives errors), but I would really prefer if I could trigger
        such an analyze manually so that I can inspect the file first.

        At least you should add the --disable-installer option to the latex call
        when miktex is used so that the installation routine is not called.

        Ulrike Fischer


        AW: [texstudio:discussion] How to disable on-the-fly installation
        dialog when opening a document?
        https://sourceforge.net/p/texstudio/discussion/907840/thread/38893d9f/?limit=25#44cb/2666


        Sent from sourceforge.net because you indicated interest in
        https://sourceforge.net/p/texstudio/discussion/907840/

        To unsubscribe from further messages, please visit
        https://sourceforge.net/auth/subscriptions/

         
  • U_Fischer
    U_Fischer
    2013-11-07

    Ah. That's the problem. kpsewhich starts the installation dialog. but findtexmf bg.sty simply returns nothing. I had thought the two commands are aliasses on miktex but this is not the case. I will try to find out what's happening but not today.

     
  • U_Fischer
    U_Fischer
    2013-11-07

    Christian Schenk has answered to my miktex bug report: One can disable the autoinstall with kpsewhich by setting this environment variable:

    set MIKTEX_KPSEWHICH_MPM_AUTOINSTALL=no

    I tested it, it works fine.

    Ulrike Fischer