comand autocomplete very slow on os X (crash)

TXS - Help
elwood151
2011-02-23
2012-10-17
  • elwood151

    elwood151 - 2011-02-23

    Hi,
    I'm testing TexMakerX on Mac OS X 10.6.5 and it mostly works fine.
    However, I'm having big trouble with the command autocomplete function.

    I disabled the automatic autocomplete in the preferences, because it was very
    slow.
    I defined Alt-Tab as shortcut for the autocompletion, but I'm not sure if I
    did that right, because in the Idefix menu, there are 3 entries for
    autocomplete:
    normal
    \begin..
    Normal Text

    what's the difference between "normal" and "normal text"?

    As soon as I try to autocomplete a command (say "\ci" for \cite{),
    the spinning beach ball is shown, TMX consumes 80..99% of CPU and nothing
    happens for at least a minute...
    for most experiments I had to kill the program, because it did not react any
    more and made the whole system slow.

    Had anybody else such experience with TMX on MacOS X?

    I'm using version 2.0 (REV 1469M).

     
  • Benito van der Zander

    "normal" is normal (commands if the word before the cursor starts with \, text
    otherwise), "normal text" only completes text.

    Does the autocompletion scan them? Can I disable that?
    Yes, it adds every pair of \citecommand and {bibtexid} to the list. The
    advanced "parse bibtex" options in the first page of the config dialog should
    turn it off.

     
  • elwood151

    elwood151 - 2011-02-23

    Thanks, benibela,

    after disabling "parse bibtex", everything works fine!

    FYI: The only drawback is, that the predefined keyboard shortcuts Cmd-Space
    and Cmd-Alt-Space are used in MacOS X for the system wide Spotlight (file)
    search, so on the Mac they have to be changed to sth else.
    (I took Alt-Tab and Alt-Shift-Tab for normal and environments).

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks