$PATH is not working

TXS - Help
Thiago
2013-01-23
2013-01-27
  • Thiago

    Thiago - 2013-01-23

    My $PATH variable is

    /usr/local/texlive/2011/bin/i386-linux:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
    

    but when I use the Help menu to see the summary of LaTeX installation, I find

    PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
    

    So I believe this is the reason to always have the error

    Error: Could not start the command: latex "foo".tex
    

    If I use the whole path

    "/usr/local/texlive/2011/bin/i386-linux/latex"  %.tex
    

    then it works. What is the problem?

     
  • Tim Hoffmann

    Tim Hoffmann - 2013-01-25

    So I believe this is the reason to always have the error

    Yes.

    What is the problem?

    Apparently the environment of processes created by TXS is different from your system environment.

    Do you know how /usr/local/texlive/2011/bin/i386-linux is added to your path? Which OS are you using?

    but when I use the Help menu to see the summary of LaTeX installation, I find

    what does it tell for which pdflatex at the top?

     
    • Thiago

      Thiago - 2013-01-26

      Do you know how /usr/local/texlive/2011/bin/i386-linux is added to your path? Which OS are you using?

      I used some export command, if I remember. I'm using

      Linux vaio 3.0.0-16-generic-pae #28-Ubuntu SMP Fri Jan 27 19:24:01 UTC 2012 i686 i686 i386 GNU/Linux
      

      what does it tell for which pdflatex at the top?

      Here is the first 3 lines

      which pdflatex: /usr/local/texlive/2011/bin/i386-linux//pdflatex
      PDFLATEX: pdflatex -version
      pdfTeX 3.1415926-2.3-1.40.12 (TeX Live 2011)
      
       
  • Benito van der Zander

    How did you check your PATH variable?

    Often programs started from the gui and from the terminal have different
    environment options.

    Try to start texstudio from bash, then you should see the same path.

    You can also set the missing path in
    Options\Configure..\Build\Additional search paths (advanced option)\Commands

     
    • Thiago

      Thiago - 2013-01-27

      You are right. Starting from the bash I see the right path. Starting from the icon on menu, don't. Interesting!

      Sometimes I open it from menu but sometimes I run a script which start TXS from the bash. So I'm trying to use the Additional search paths as you said but it is not saving the option.

       
      Last edit: Thiago 2013-01-27

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks