How to reinstall TeXstudio

TXS - Help
Dongmei Xu
2013-01-16
2013-01-16
  • Dongmei Xu

    Dongmei Xu - 2013-01-16

    My TeXstudio cannot track the text with the PDF correctly, the yellow background always goes wrong place. So i'm trying to reinstall it. But after the reinstallation, the former configuration before my uninstall was still there. How to solve this?

     
  • Tim Hoffmann

    Tim Hoffmann - 2013-01-16

    To reset the configuration just delete texstudio.ini:
    https://sourceforge.net/apps/mediawiki/texstudio/index.php?title=Frequently_Asked_Questions

    But that's likely not related to your syncing issue. Have you changed your source file after the last compilation? Syncing works via synctex, which can only relate the line numbers of the source to the pdf during compilation. If you change the source afterwards the line numbers may not match anymore and you will end up in the wrong place.

     
    • Dongmei Xu

      Dongmei Xu - 2013-01-16

      I searched in my whole computer, no texstudio.ini has been found. I didn't move the source. No matter how many times i have recompilied, it's just always locating the wrong place with the same direction. It seems the algorithm for calculating the line numbers has been added some fixed number.

       
  • Tim Hoffmann

    Tim Hoffmann - 2013-01-16

    ini location: Look again at the above link (section: Where are the settings stored?).

    sync offset: Then try deleting yourtexfile.synctex.gz, which is created in the folder next to your tex file. Recompile. Is the synctex.gz file recreated? If so, is the offset still present? If so, please provide an example file that shows this behavior.

     
  • Dongmei Xu

    Dongmei Xu - 2013-01-16

    I just install Tex Live and remove miktex, then synctex works.

     
  • Dongmei Xu

    Dongmei Xu - 2013-01-16

    Thanks for your helps, good night!

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks