SSSE3 use on OSX version

Nuno Cruz
2014-01-29
2014-02-14
  • Nuno Cruz

    Nuno Cruz - 2014-01-29

    Hi all,

    When I try to run 2.6.6e for osx I get an error from qt saying that SSSE3 isn't supported by my CPU, which is right, my CPU doesn't have SSSE3 support.

    If I try running 2.6.6 with qt4 it works.

    I've tried building it from source (following instructions on the wiki) without ssse3 support but it didn't work, I got some errors about libjpeg (dyld: Symbol not found: __cg_jpeg_resync_to_restart) and pthreads (debughelper.cpp:651:19: error: use of undeclared identifier 'pthread_self').

    2.7 beta for osx algo gives an error about libjpeg no being in /opt.

    So, can I ask for updated wiki on how to build texstudio on osx 10.9 or for a version without ssse3 support?

    Thanks!

     
    • Jan  Sundermeyer

      Jan Sundermeyer - 2014-01-29

      do you have qt5 installed on your computer ?
      Do you have poppler installed as well ?

      On 29.01.2014 18:38, Nuno Cruz wrote:

      Hi all,

      When I try to run 2.6.6e for osx I get an error from qt saying that
      SSSE3 isn't supported by my CPU, which is right, my CPU doesn't have
      SSSE3 support.

      If I try running 2.6.6 with qt4 it works.

      I've tried building it from source (following instructions on the wiki)
      without ssse3 support but it didn't work, I got some errors about
      libjpeg (dyld: Symbol not found: __cg_jpeg_resync_to_restart) and
      pthreads (debughelper.cpp:651:19: error: use of undeclared identifier
      'pthread_self').

      2.7 beta for osx algo gives an error about libjpeg no being in /opt.

      So, can I ask for updated wiki on how to build texstudio on osx 10.9 or
      for a version without ssse3 support?

      Thanks!


      SSSE3 use on OSX version
      https://sourceforge.net/p/texstudio/discussion/907839/thread/7fe8b03b/?limit=25#f726


      Sent from sourceforge.net because you indicated interest in
      https://sourceforge.net/p/texstudio/discussion/907839/

      To unsubscribe from further messages, please visit
      https://sourceforge.net/auth/subscriptions/

       
  • Nuno Cruz

    Nuno Cruz - 2014-01-30

    Hi, yes poppler is installed, i tried now with qt5 and get

    make: *** No rule to make target /usr/local/Cellar/qt5/5.2.0/lib/libQt5UiTools_debug.a', needed bytexstudio.app/Contents/MacOS/texstudio'. Stop.

    If I pass CONFIG=release to qmake and still use qt5, i get during make the following error:
    PDFDocument.h:36:10: fatal error: 'poppler-qt5.h' file not found

     
    • Jan  Sundermeyer

      Jan Sundermeyer - 2014-01-30

      you have to supply the path to poppler in texstudio.pro (about line 534)
      INCLUDPATH contains *.h , LIBS contain the actually libraries.

      On 30.01.2014 12:46, Nuno Cruz wrote:

      Hi, yes poppler is installed, i tried now with qt5 and get

      make: *** No rule to make target
      |/usr/local/Cellar/qt5/5.2.0/lib/libQt5UiTools_debug.a', needed
      by|texstudio.app/Contents/MacOS/texstudio'. Stop.

      If I pass CONFIG=release to qmake and still use qt5, i get during make
      the following error:
      PDFDocument.h:36:10: fatal error: 'poppler-qt5.h' file not found


      SSSE3 use on OSX version
      https://sourceforge.net/p/texstudio/discussion/907839/thread/7fe8b03b/?limit=25#a084


      Sent from sourceforge.net because you indicated interest in
      https://sourceforge.net/p/texstudio/discussion/907839/

      To unsubscribe from further messages, please visit
      https://sourceforge.net/auth/subscriptions/

       
  • Nuno Cruz

    Nuno Cruz - 2014-01-30

    The poppler installed from homebrew doesn't support qt5, I've tried to build it with qt5 support, but no matter what I do, the configure of poppler doesn't find qt5, even after setting QTDIR and POPPLER_QT5_* env vars.

    I'm going to give up for now and keep using 2.6.6...

     
  • Nuno Cruz

    Nuno Cruz - 2014-01-31

    2.6.6 is working fine, I'm just afraid that newer versions (such as 2.6.6e) will introduce the requirement for SSSE3 within qt5 and was trying to get ahead and compile it by myself...

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks