Problems with BibTex caused by configuration

Anonymous
2012-07-16
2013-12-04
  • Anonymous - 2012-07-16

    Hello everybody,

    I use TexStudio 2.3 and MikTex 2.9 and I got some probelms with bibtex when I
    tried to create cites and bibliography. After citing do not work in my thesis
    file, I tried this simple example http://latex.hpfsc.de/content/latex_tutoria
    l/literatur_bibtex
    . But it does not work either. I only got '?' and no bibliografie, LaTex
    says that the citation is undefined.
    I tried it with compiling PDFLatex, BibTex, PDFLatex, PDFLatex.
    My guess is that the configuration of my TexStudio is wrong as I did not even
    create an bbl file, but I have no idea how to fix it.

    I would be very pleased, if somebody can help me.

    Thanks,
    Britta

     
  • Nobody/Anonymous

    what does the bibtex output say? (enable advanced options and set Configure ->
    Build -> Show stdout to "always")

     
  • Anonymous - 2012-07-16

    It says
    Process started: bibtex "References".aux

    Process exited normally

     
  • Anonymous - 2012-07-16

    Sorry, and the rest I do not get. Where can I enable advanced options?
    And where do I found the option stdout to 'always'?

    Thanks

     
  • Nobody/Anonymous

    Where can I enable advanced options?
    Check box in the bottom left corner of the options dialog

    And where do I found the option stdout to 'always'?
    Options dialog: Build -> Build options -> Show stdout

     
  • Anonymous - 2012-07-16

    okay... I am confused.
    I am in TexStudio and I could not find these dialogs. Do you talk about
    something else?

     
  • Nobody/Anonymous

    Thanks for the picture. I do not have these quick built options in my
    TexStudio. I will install TexStudio again...

     
  • Anonymous - 2012-07-18

    okay, I finnally got it. But the output form bibtex is still the same:
    Process started: bibtex "References".aux Process exited normally

     
  • Tim Hoffmann

    Tim Hoffmann - 2012-07-18
    1. are you sure, you've set "show stdout" to always? The output should be something like this:

    Process started: bibtex "beispiel07"

    This is BibTeX, Version 0.99d (Web2C 2011)
    The top-level auxiliary file: beispiel07.aux
    The style file: alphadin.bst
    Database file #1: literatur.bib
    Warning--empty note in pasche1992
    (There was 1 warning)

    Process exited normally

    1. Try running "bibtex References.aux" from the command line in the directory of your tex file. What is the output there?
     
  • Nobody/Anonymous

    Thanks again a lot for your help.
    I do not know what the problem is, but I decided to work with an other editor.
    This works well.
    Bye,
    Britta

     
  • headphones54321

    headphones54321 - 2013-07-16

    Hello, I'm having the same issue, and like TeXstudio, so would like to help fix it.

    I have a project that has multiple \includes. When I build and compile bibtex is never run, and I get a bunch of undefined citations, and a "No file thesis.bbl" error.

    If I compile, then go Tools->Bibliography (ie. run bibtex manually), then compile again, it works fine.

    In all my other, single file projects, in TeXstudio, bibtex has run automatically. Is there something about multiple file projects, or has something in my installation changed?

    TeXstudio 2.6.0 on Ubuntu 12.10, 64 bit

     
    • einhander

      einhander - 2013-12-04

      Hi, I have same here at my Texstudio 2.6.6 jessie i386 from repo. Bibtex never starts on my big project. But single file is ok. I removed my profile and created new, but it wont help. Help me.

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks