Mac command problem

2012-03-11
2012-10-17
  • Kihwang Lee

    Kihwang Lee - 2012-03-11

    Hi!

    I am using texstuio 2.3 on Mac OS X 10.7 (Lion) with MacTeX 2011. I prefer
    xelatex over pdflatex, and I replaced pdflatex with xelatex in Tools.
    Therefore, the command for PdfLaTeX became '"/usr/texbin/xelatex" -synctex=1
    -interaction=nonstopmode %s.tex'. When I run PDFLaTeX (F6), the output window
    shows the following message:

    Process started: /usr/texbin/xelatex -interaction=nonstopmode "rep120212".tex
    sh: xdvipdfmx: command not found
    Error: Command crashed: /usr/texbin/xelatex -interaction=nonstopmode
    "rep120212".tex
    Process exited normally

    As far as I know, xdvipdfmx is internally called by xelatex.
    My TeX system works fine in terminal window and texmaker works well with a
    same settings.
    I tried to modify the path (by modifying /etc/paths.d/texlive) to use real tex
    binary directory (/usr/local/texlive/2011/bin/x86_64-darwin) but failed. It
    seems that the shell used in texstudio does not properly inherit enviroment
    variables from OS.

    Many thanks in advance.

    Kihwang

     
  • Nobody/Anonymous

    I'm having the same issue with the exact same setup. Did you find a solution?

    CL

     
  • Nobody/Anonymous

    Solution :
    in TexStudio's preferences/compilation pane, the xelatex field should read

    /usr/texbin/xelatex -synctex=1 -interaction=nonstopmode -output-
    driver="/usr/texbin/xdvipdfmx -q -E" %.tex

    notice the full path to the output driver

     
  • Benito van der Zander

    Nice, finally someone who knows xelatex...

    But in txs 2.4, you can (probably) also add /usr/texbin to the
    additional search paths on the advanced build config page to make it
    work (in fact that option should automatically be set there on mac).

    On 09/19/2012 11:43 AM, SourceForge.net wrote:

     
  • Denis Bitouzé

    Denis Bitouzé - 2012-09-20

    in fact that option should automatically be set there on mac

    On the few Mac where I helped to install both LaTeX (via MacTeX) and
    TeXstudio, I always was facing the trouble that /usr/texbin isn't in the path.
    I guess it is because MacTeX for some reasons doesn't want to change the OS
    path and probably (I didn't check) hardcodes the TeX path in the editors
    TeXworks and TeXshop it provides.

     
  • Nobody/Anonymous

    Explicitly specifying the output driver (see solution in post 3) worked for
    me. I'm grateful. Thanks!

    CL

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks