#688 Log file and error tabs not updating to reflect change ?

None
fixed
nobody
None
3
2013-03-02
2013-02-13
No

Good day,

On Win 7 - 64-bit with Miktex 2.9 64-bit when I open TexStudio for the first time and compile my tex file, the Log File and Error tabs at the bottom reflect correctly any issues. However when I change/update/rectify the issues and recompile ... it does not reflect the changes in the two tabs. Even Tools->"Clear Auxillary Files ..." and recompiling does not fix the issues ... Older TexStudio versions worked ... what am I doing wrong or is it a bug?

Best regards,

Dawie

Discussion

  • Dawie Joubert

    Dawie Joubert - 2013-02-13

    This is with the stock-standard TexStudio 2.5.2 - 32-bit

     
  • Tim Hoffmann

    Tim Hoffmann - 2013-02-13

    That's strange.

    What happens to the .log file? Does it update on disk when compiling? Is it deleted on Clean Auxiliary Files?

     
  • Dawie Joubert

    Dawie Joubert - 2013-02-14

    The log file gets correctly updated ... but its contents within the texstudio log tab window does not get updated. In fact ... it looks as if it did not even display the entire log file when it was first generated ... it stopped in mid sentence/word ...

    Does texstudio have a log that I could submit?

     
    Last edit: Dawie Joubert 2013-02-14
  • Tim Hoffmann

    Tim Hoffmann - 2013-02-14
    1. Can you provide a sample tex file where this happens?

    2. Does it happen with every tex file?

    3. Are you using any more refined LaTeX features (multi-file document, aux-directory, output-directory, ...)

     
  • Dawie Joubert

    Dawie Joubert - 2013-02-15

    Attached is the example.

    So far all the latex files I have been using have caused this behaviour.

    I am not currently using the multi-file document features, or any of the other "refined features" ... stock standard ...

     
  • Tim Hoffmann

    Tim Hoffmann - 2013-02-19

    Strange. I can't reproduce this. For me it works like it should.

    I have to ponder over this further.

     
  • Benito van der Zander

    Can you send us the log file?

    Related: #695

     
  • Dawie Joubert

    Dawie Joubert - 2013-03-02

    Hi all,

    I will attach the log file. BUT, I am not sure how it will help, the reason for my doubts are as follows:
    1) The first time TexStudio starts it works perfectly when you press F1 for building;
    2) After the first build once the program started it never updates the Log or Error tabs;
    3) Only by shutting down the application and restarting it does it update the Log and Error tab;

    But then again ... I don't know TexStudios internsal, hence my question about TexStudio's own log file / debug build?

    Best regards,

    Dawie

     
  • Benito van der Zander

    • status: open --> closed
    • milestone: -->
     
  • Benito van der Zander

    After the discussion in 695 it turned out that this happens, if you call pdflatex (or another latex command) directly, instead of using txs:///pdflatex.

    So it will probably work, if you adjust your compile command.

    (and starting from r3776 both will work the same)

     
  • Benito van der Zander

    • status: closed --> fixed
     
  • Dawie Joubert

    Dawie Joubert - 2013-03-02

    That was it!!!
    Thank you kindly!

    PS. Shouldn't you have a built in log file that you could inspect from TexStudios' perspective?

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks